summaryrefslogtreecommitdiffstats
path: root/examples/wayland/server-side-decoration/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/wayland/server-side-decoration/CMakeLists.txt')
-rw-r--r--examples/wayland/server-side-decoration/CMakeLists.txt18
1 files changed, 7 insertions, 11 deletions
diff --git a/examples/wayland/server-side-decoration/CMakeLists.txt b/examples/wayland/server-side-decoration/CMakeLists.txt
index dc95b805f..b56e96947 100644
--- a/examples/wayland/server-side-decoration/CMakeLists.txt
+++ b/examples/wayland/server-side-decoration/CMakeLists.txt
@@ -1,38 +1,34 @@
-# Generated from server-side-decoration.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: LicenseRef-Qt-Commercial OR BSD-3-Clause
-cmake_minimum_required(VERSION 3.14)
+cmake_minimum_required(VERSION 3.16)
project(server-side-decoration LANGUAGES CXX)
-set(CMAKE_INCLUDE_CURRENT_DIR ON)
-
set(CMAKE_AUTOMOC ON)
-set(CMAKE_AUTORCC ON)
-set(CMAKE_AUTOUIC ON)
if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
+ set(INSTALL_EXAMPLESDIR "examples")
endif()
set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/wayland/server-side-decoration")
-find_package(Qt6 COMPONENTS Core)
-find_package(Qt6 COMPONENTS Gui)
-find_package(Qt6 COMPONENTS Qml)
+find_package(Qt6 REQUIRED COMPONENTS Core Gui Qml)
qt_add_executable(server-side-decoration
main.cpp
)
+
set_target_properties(server-side-decoration PROPERTIES
WIN32_EXECUTABLE TRUE
MACOSX_BUNDLE TRUE
)
+
target_link_libraries(server-side-decoration PUBLIC
Qt::Core
Qt::Gui
Qt::Qml
)
-
# Resources:
set(server-side-decoration_resource_files
"main.qml"