summaryrefslogtreecommitdiffstats
path: root/src/hardwareintegration/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/hardwareintegration/CMakeLists.txt')
-rw-r--r--src/hardwareintegration/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/hardwareintegration/CMakeLists.txt b/src/hardwareintegration/CMakeLists.txt
new file mode 100644
index 000000000..bc75a2088
--- /dev/null
+++ b/src/hardwareintegration/CMakeLists.txt
@@ -0,0 +1,9 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+if(TARGET Qt::WaylandClient)
+ add_subdirectory(client)
+endif()
+if(TARGET Qt::WaylandCompositor)
+ add_subdirectory(compositor)
+endif()