summaryrefslogtreecommitdiffstats
path: root/src/hardwareintegration/compositor/wayland-egl/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/hardwareintegration/compositor/wayland-egl/CMakeLists.txt')
-rw-r--r--src/hardwareintegration/compositor/wayland-egl/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/hardwareintegration/compositor/wayland-egl/CMakeLists.txt b/src/hardwareintegration/compositor/wayland-egl/CMakeLists.txt
index c88c438d8..f31928550 100644
--- a/src/hardwareintegration/compositor/wayland-egl/CMakeLists.txt
+++ b/src/hardwareintegration/compositor/wayland-egl/CMakeLists.txt
@@ -1,3 +1,6 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
#####################################################################
## WaylandEglCompositorHwIntegrationPrivate Module:
#####################################################################
@@ -18,6 +21,7 @@ qt_internal_add_module(WaylandEglCompositorHwIntegrationPrivate
Qt::Core
Qt::Gui
Qt::WaylandCompositorPrivate
+ NO_GENERATE_CPP_EXPORTS
)
qt_internal_extend_target(WaylandEglCompositorHwIntegrationPrivate CONDITION NOT QT_FEATURE_egl_x11