summaryrefslogtreecommitdiffstats
path: root/src/imports/compositor-extensions/wlshell/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/imports/compositor-extensions/wlshell/CMakeLists.txt')
-rw-r--r--src/imports/compositor-extensions/wlshell/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/imports/compositor-extensions/wlshell/CMakeLists.txt b/src/imports/compositor-extensions/wlshell/CMakeLists.txt
index b8c9586bb..0dd155e35 100644
--- a/src/imports/compositor-extensions/wlshell/CMakeLists.txt
+++ b/src/imports/compositor-extensions/wlshell/CMakeLists.txt
@@ -1,3 +1,6 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
# Generated from wlshell.pro.
#####################################################################
@@ -19,8 +22,11 @@ qt_internal_add_qml_module(WaylandCompositorWLShell
Qt::Core
Qt::Gui
Qt::WaylandCompositor
+ NO_GENERATE_CPP_EXPORTS
)
+qt_internal_add_autogen_sync_header_dependencies(WaylandCompositorWLShell WaylandCompositor)
+
#### Keys ignored in scope 1:.:.:wlshell.pro:<TRUE>:
# CXX_MODULE = "qml"
# QML_IMPORT_VERSION = "$$QT_VERSION"