summaryrefslogtreecommitdiffstats
path: root/src/imports/compositor-extensions/wlshell/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/imports/compositor-extensions/wlshell/CMakeLists.txt')
-rw-r--r--src/imports/compositor-extensions/wlshell/CMakeLists.txt24
1 files changed, 9 insertions, 15 deletions
diff --git a/src/imports/compositor-extensions/wlshell/CMakeLists.txt b/src/imports/compositor-extensions/wlshell/CMakeLists.txt
index a88abe1f2..8987621d3 100644
--- a/src/imports/compositor-extensions/wlshell/CMakeLists.txt
+++ b/src/imports/compositor-extensions/wlshell/CMakeLists.txt
@@ -1,23 +1,17 @@
-# Generated from wlshell.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
-#####################################################################
-## qwaylandcompositorwlshellplugin Plugin:
-#####################################################################
-
-qt_internal_add_qml_module(qwaylandcompositorwlshellplugin
+qt_internal_add_qml_module(WaylandCompositorWLShell
URI "QtWayland.Compositor.WlShell"
- VERSION "${CMAKE_PROJECT_VERSION}"
- CLASSNAME QWaylandCompositorWlShellPlugin
- SKIP_TYPE_REGISTRATION
+ VERSION "${PROJECT_VERSION}"
SOURCES
- qwaylandcompositorwlshellplugin.cpp
- PUBLIC_LIBRARIES
+ qwaylandcompositorwlshell_p.h qwaylandcompositorwlshell.cpp
+ LIBRARIES
Qt::Core
Qt::Gui
Qt::WaylandCompositor
+ NO_GENERATE_CPP_EXPORTS
+ PAST_MAJOR_VERSIONS 1
)
-#### Keys ignored in scope 1:.:.:wlshell.pro:<TRUE>:
-# CXX_MODULE = "qml"
-# QML_IMPORT_VERSION = "$$QT_VERSION"
-# TARGETPATH = "QtWayland/Compositor/WlShell"
+qt_internal_add_autogen_sync_header_dependencies(WaylandCompositorWLShell WaylandCompositor)