summaryrefslogtreecommitdiffstats
path: root/src/imports/compositor-extensions/xdgshell/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/imports/compositor-extensions/xdgshell/CMakeLists.txt')
-rw-r--r--src/imports/compositor-extensions/xdgshell/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/src/imports/compositor-extensions/xdgshell/CMakeLists.txt b/src/imports/compositor-extensions/xdgshell/CMakeLists.txt
new file mode 100644
index 000000000..32f032d93
--- /dev/null
+++ b/src/imports/compositor-extensions/xdgshell/CMakeLists.txt
@@ -0,0 +1,18 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+qt_internal_add_qml_module(WaylandCompositorXdgShell
+ URI "QtWayland.Compositor.XdgShell"
+ VERSION "${PROJECT_VERSION}"
+ SOURCES
+ qwaylandcompositorxdgshell_p.h
+ qwaylandcompositorxdgshell.cpp
+ LIBRARIES
+ Qt::Core
+ Qt::Gui
+ Qt::WaylandCompositor
+ NO_GENERATE_CPP_EXPORTS
+ PAST_MAJOR_VERSIONS 1
+)
+
+qt_internal_add_autogen_sync_header_dependencies(WaylandCompositorXdgShell WaylandCompositor)