summaryrefslogtreecommitdiffstats
path: root/src/imports/compositor-extensions/xdgshell/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/imports/compositor-extensions/xdgshell/CMakeLists.txt')
-rw-r--r--src/imports/compositor-extensions/xdgshell/CMakeLists.txt25
1 files changed, 10 insertions, 15 deletions
diff --git a/src/imports/compositor-extensions/xdgshell/CMakeLists.txt b/src/imports/compositor-extensions/xdgshell/CMakeLists.txt
index 00210ab21..32f032d93 100644
--- a/src/imports/compositor-extensions/xdgshell/CMakeLists.txt
+++ b/src/imports/compositor-extensions/xdgshell/CMakeLists.txt
@@ -1,23 +1,18 @@
-# Generated from xdgshell.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
-#####################################################################
-## qwaylandcompositorxdgshellplugin Plugin:
-#####################################################################
-
-qt_internal_add_qml_module(qwaylandcompositorxdgshellplugin
+qt_internal_add_qml_module(WaylandCompositorXdgShell
URI "QtWayland.Compositor.XdgShell"
- VERSION "${CMAKE_PROJECT_VERSION}"
- CLASSNAME QWaylandCompositorXdgShellPlugin
- SKIP_TYPE_REGISTRATION
+ VERSION "${PROJECT_VERSION}"
SOURCES
- qwaylandcompositorxdgshellplugin.cpp
- PUBLIC_LIBRARIES
+ qwaylandcompositorxdgshell_p.h
+ qwaylandcompositorxdgshell.cpp
+ LIBRARIES
Qt::Core
Qt::Gui
Qt::WaylandCompositor
+ NO_GENERATE_CPP_EXPORTS
+ PAST_MAJOR_VERSIONS 1
)
-#### Keys ignored in scope 1:.:.:xdgshell.pro:<TRUE>:
-# CXX_MODULE = "qml"
-# QML_IMPORT_VERSION = "$$QT_VERSION"
-# TARGETPATH = "QtWayland/Compositor/XdgShell"
+qt_internal_add_autogen_sync_header_dependencies(WaylandCompositorXdgShell WaylandCompositor)