summaryrefslogtreecommitdiffstats
path: root/src/imports/compositor
diff options
context:
space:
mode:
Diffstat (limited to 'src/imports/compositor')
-rw-r--r--src/imports/compositor/CMakeLists.txt4
-rw-r--r--src/imports/compositor/WaylandCursorItem.qml5
-rw-r--r--src/imports/compositor/WaylandOutputWindow.qml3
-rw-r--r--src/imports/compositor/compositor.pro2
-rw-r--r--src/imports/compositor/plugins.qmltypes20
-rw-r--r--src/imports/compositor/qwaylandquickcompositorplugin.cpp5
6 files changed, 18 insertions, 21 deletions
diff --git a/src/imports/compositor/CMakeLists.txt b/src/imports/compositor/CMakeLists.txt
index 936701695..1f51d6362 100644
--- a/src/imports/compositor/CMakeLists.txt
+++ b/src/imports/compositor/CMakeLists.txt
@@ -6,7 +6,7 @@
qt_add_qml_module(qwaylandcompositorplugin
URI "QtWayland.Compositor"
- VERSION "1.${CMAKE_PROJECT_VERSION_MINOR}"
+ VERSION "${CMAKE_PROJECT_VERSION}"
CLASSNAME QWaylandCompositorPlugin
SKIP_TYPE_REGISTRATION
SOURCES
@@ -26,8 +26,8 @@ qt_add_qml_module(qwaylandcompositorplugin
#### Keys ignored in scope 1:.:.:compositor.pro:<TRUE>:
# COMPOSITOR_QML_FILES = "WaylandOutputWindow.qml" "WaylandCursorItem.qml"
# CXX_MODULE = "qml"
-# IMPORT_VERSION = "1.$$QT_MINOR_VERSION"
# QMAKE_QMLPLUGINDUMP_FLAGS = "-defaultplatform"
+# QML_IMPORT_VERSION = "$$QT_VERSION"
# RESOURCE_CONTENT = "<RCC>" "<qresource prefix="/QtWayland/Compositor">" "</qresource>" "</RCC>"
# TARGETPATH = "QtWayland/Compositor"
diff --git a/src/imports/compositor/WaylandCursorItem.qml b/src/imports/compositor/WaylandCursorItem.qml
index bb0a840a4..ba2e044c4 100644
--- a/src/imports/compositor/WaylandCursorItem.qml
+++ b/src/imports/compositor/WaylandCursorItem.qml
@@ -27,9 +27,8 @@
**
****************************************************************************/
-import QtQuick 2.0
-import QtWayland.Compositor 1.0
-import QtQuick.Window 2.11
+import QtQuick
+import QtWayland.Compositor
WaylandQuickItem {
id: cursorItem
diff --git a/src/imports/compositor/WaylandOutputWindow.qml b/src/imports/compositor/WaylandOutputWindow.qml
index d75a20c98..0462a9a2f 100644
--- a/src/imports/compositor/WaylandOutputWindow.qml
+++ b/src/imports/compositor/WaylandOutputWindow.qml
@@ -27,8 +27,7 @@
**
****************************************************************************/
-import QtQuick 2.0
-import QtQuick.Window 2.2
+import QtQuick
Window {
id: window
diff --git a/src/imports/compositor/compositor.pro b/src/imports/compositor/compositor.pro
index 59dd7824c..4d5b82b8d 100644
--- a/src/imports/compositor/compositor.pro
+++ b/src/imports/compositor/compositor.pro
@@ -1,7 +1,7 @@
CXX_MODULE = qml
TARGET = qwaylandcompositorplugin
TARGETPATH = QtWayland/Compositor
-IMPORT_VERSION = 1.$$QT_MINOR_VERSION
+QML_IMPORT_VERSION = $$QT_VERSION
HEADERS += \
qwaylandmousetracker_p.h
diff --git a/src/imports/compositor/plugins.qmltypes b/src/imports/compositor/plugins.qmltypes
index 8f0622114..90f5457a0 100644
--- a/src/imports/compositor/plugins.qmltypes
+++ b/src/imports/compositor/plugins.qmltypes
@@ -341,7 +341,7 @@ Module {
}
Method {
name: "mapFromSurface"
- revision: 65293
+ revision: 269
type: "QPointF"
Parameter { name: "point"; type: "QPointF" }
}
@@ -503,15 +503,15 @@ Module {
}
}
Property { name: "client"; type: "QWaylandClient"; isReadonly: true; isPointer: true }
- Property { name: "sourceGeometry"; revision: 65293; type: "QRectF"; isReadonly: true }
- Property { name: "destinationSize"; revision: 65293; type: "QSize"; isReadonly: true }
- Property { name: "bufferSize"; revision: 65293; type: "QSize"; isReadonly: true }
+ Property { name: "sourceGeometry"; revision: 269; type: "QRectF"; isReadonly: true }
+ Property { name: "destinationSize"; revision: 269; type: "QSize"; isReadonly: true }
+ Property { name: "bufferSize"; revision: 269; type: "QSize"; isReadonly: true }
Property { name: "bufferScale"; type: "int"; isReadonly: true }
Property { name: "contentOrientation"; type: "Qt::ScreenOrientation"; isReadonly: true }
Property { name: "origin"; type: "QWaylandSurface::Origin"; isReadonly: true }
Property { name: "hasContent"; type: "bool"; isReadonly: true }
Property { name: "cursorSurface"; type: "bool" }
- Property { name: "inhibitsIdle"; revision: 65294; type: "bool"; isReadonly: true }
+ Property { name: "inhibitsIdle"; revision: 270; type: "bool"; isReadonly: true }
Signal {
name: "damaged"
Parameter { name: "rect"; type: "QRegion" }
@@ -525,9 +525,9 @@ Module {
name: "childAdded"
Parameter { name: "child"; type: "QWaylandSurface"; isPointer: true }
}
- Signal { name: "sourceGeometryChanged"; revision: 65293 }
- Signal { name: "destinationSizeChanged"; revision: 65293 }
- Signal { name: "bufferSizeChanged"; revision: 65293 }
+ Signal { name: "sourceGeometryChanged"; revision: 269 }
+ Signal { name: "destinationSizeChanged"; revision: 269 }
+ Signal { name: "bufferSizeChanged"; revision: 269 }
Signal {
name: "offsetForNextFrame"
Parameter { name: "offset"; type: "QPoint" }
@@ -755,7 +755,7 @@ Module {
type: "uint"
Parameter { name: "geometry"; type: "QRect" }
}
- Method { name: "sendPopupDone"; revision: 65294 }
+ Method { name: "sendPopupDone"; revision: 270 }
}
Component {
name: "QWaylandXdgShell"
@@ -922,7 +922,7 @@ Module {
Property { name: "hotspotY"; type: "int" }
}
Component {
- prototype: "QQuickWindow"
+ prototype: "QQuickWindowQmlImpl"
name: "QtWayland.Compositor/WaylandOutputWindow 1.0"
exports: ["QtWayland.Compositor/WaylandOutputWindow 1.0"]
exportMetaObjectRevisions: [0]
diff --git a/src/imports/compositor/qwaylandquickcompositorplugin.cpp b/src/imports/compositor/qwaylandquickcompositorplugin.cpp
index de3a34a77..2977af8c2 100644
--- a/src/imports/compositor/qwaylandquickcompositorplugin.cpp
+++ b/src/imports/compositor/qwaylandquickcompositorplugin.cpp
@@ -93,7 +93,6 @@ private:
const QString m_qrcPath;
};
-
//![class decl]
class QWaylandCompositorPlugin : public QQmlExtensionPlugin
{
@@ -119,8 +118,8 @@ public:
static void defineModule(const char *uri)
{
// The minor version used to be the current Qt 5 minor. For compatibility it is the last
- // Qt 5 release.
- qmlRegisterModule(uri, 1, 15);
+ // Qt release.
+ qmlRegisterModule(uri, QT_VERSION_MAJOR, QT_VERSION_MINOR);
qmlRegisterType<QWaylandQuickCompositorQuickExtensionContainer>(uri, 1, 0, "WaylandCompositor");
qmlRegisterType<QWaylandQuickItem>(uri, 1, 0, "WaylandQuickItem");