summaryrefslogtreecommitdiffstats
path: root/src/imports/texture-sharing-extension/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/imports/texture-sharing-extension/CMakeLists.txt')
-rw-r--r--src/imports/texture-sharing-extension/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/imports/texture-sharing-extension/CMakeLists.txt b/src/imports/texture-sharing-extension/CMakeLists.txt
index 575f80a1e..564bb6402 100644
--- a/src/imports/texture-sharing-extension/CMakeLists.txt
+++ b/src/imports/texture-sharing-extension/CMakeLists.txt
@@ -1,3 +1,6 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
# Generated from texture-sharing-extension.pro.
#####################################################################
@@ -24,8 +27,10 @@ qt_internal_add_qml_module(WaylandTextureSharingExtension
Qt::QuickPrivate
Qt::WaylandCompositor
Qt::WaylandCompositorPrivate
+ NO_GENERATE_CPP_EXPORTS
)
+qt_internal_add_autogen_sync_header_dependencies(WaylandTextureSharingExtension WaylandCompositor)
#### Keys ignored in scope 1:.:.:texture-sharing-extension.pro:<TRUE>:
# CXX_MODULE = "qml"
# IMPORT_VERSION = "1.$$QT_MINOR_VERSION"