summaryrefslogtreecommitdiffstats
path: root/src/plugins/hardwareintegration/compositor/wayland-eglstream-controller/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/hardwareintegration/compositor/wayland-eglstream-controller/CMakeLists.txt')
-rw-r--r--src/plugins/hardwareintegration/compositor/wayland-eglstream-controller/CMakeLists.txt16
1 files changed, 9 insertions, 7 deletions
diff --git a/src/plugins/hardwareintegration/compositor/wayland-eglstream-controller/CMakeLists.txt b/src/plugins/hardwareintegration/compositor/wayland-eglstream-controller/CMakeLists.txt
index 3cbe8f822..39c97bc5f 100644
--- a/src/plugins/hardwareintegration/compositor/wayland-eglstream-controller/CMakeLists.txt
+++ b/src/plugins/hardwareintegration/compositor/wayland-eglstream-controller/CMakeLists.txt
@@ -1,13 +1,16 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
# Generated from wayland-eglstream-controller.pro.
#####################################################################
-## QWaylandEglStreamBufferIntegrationPlugin Plugin:
+## QWaylandEglStreamClientBufferIntegrationPlugin Plugin:
#####################################################################
qt_find_package(EGL) # special case
-qt_internal_add_plugin(QWaylandEglStreamBufferIntegrationPlugin
+qt_internal_add_plugin(QWaylandEglStreamClientBufferIntegrationPlugin
OUTPUT_NAME qt-wayland-compositor-wayland-eglstream-controller
- TYPE wayland-graphics-integration-server
+ PLUGIN_TYPE wayland-graphics-integration-server
SOURCES
../../../../hardwareintegration/compositor/wayland-eglstream-controller/waylandeglstreamcontroller.cpp ../../../../hardwareintegration/compositor/wayland-eglstream-controller/waylandeglstreamcontroller.h
../../../../hardwareintegration/compositor/wayland-eglstream-controller/waylandeglstreamintegration.cpp ../../../../hardwareintegration/compositor/wayland-eglstream-controller/waylandeglstreamintegration.h
@@ -16,16 +19,15 @@ qt_internal_add_plugin(QWaylandEglStreamBufferIntegrationPlugin
../../../../hardwareintegration/compositor/wayland-eglstream-controller
LIBRARIES
EGL::EGL
- Wayland::Egl
- Wayland::Server
- PUBLIC_LIBRARIES
Qt::CorePrivate
Qt::GuiPrivate
Qt::WaylandCompositor
Qt::WaylandCompositorPrivate
+ Wayland::Egl
+ Wayland::Server
)
-qt6_generate_wayland_protocol_server_sources(QWaylandEglStreamBufferIntegrationPlugin
+qt6_generate_wayland_protocol_server_sources(QWaylandEglStreamClientBufferIntegrationPlugin
FILES
${CMAKE_CURRENT_SOURCE_DIR}/../../../../hardwareintegration/compositor/wayland-eglstream-controller/../../../3rdparty/protocol/wl-eglstream-controller.xml
)