summaryrefslogtreecommitdiffstats
path: root/src/plugins/platforms/qwayland-egl/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/platforms/qwayland-egl/CMakeLists.txt')
-rw-r--r--src/plugins/platforms/qwayland-egl/CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/src/plugins/platforms/qwayland-egl/CMakeLists.txt b/src/plugins/platforms/qwayland-egl/CMakeLists.txt
new file mode 100644
index 000000000..6473ba151
--- /dev/null
+++ b/src/plugins/platforms/qwayland-egl/CMakeLists.txt
@@ -0,0 +1,24 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+# Generated from qwayland-egl.pro.
+
+#####################################################################
+## QWaylandEglPlatformIntegrationPlugin Plugin:
+#####################################################################
+qt_find_package(EGL) # special case
+
+qt_internal_add_plugin(QWaylandEglPlatformIntegrationPlugin
+ OUTPUT_NAME qwayland-egl
+ PLUGIN_TYPE platforms
+ SOURCES
+ main.cpp
+ LIBRARIES
+ Qt::Core
+ Qt::Gui
+ Qt::WaylandClientPrivate
+ Qt::WaylandEglClientHwIntegrationPrivate
+)
+
+#### Keys ignored in scope 1:.:.:qwayland-egl.pro:<TRUE>:
+# OTHER_FILES = "qwayland-egl.json"