summaryrefslogtreecommitdiffstats
path: root/src/plugins/platforms/qwayland-egl/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/platforms/qwayland-egl/CMakeLists.txt')
-rw-r--r--src/plugins/platforms/qwayland-egl/CMakeLists.txt19
1 files changed, 6 insertions, 13 deletions
diff --git a/src/plugins/platforms/qwayland-egl/CMakeLists.txt b/src/plugins/platforms/qwayland-egl/CMakeLists.txt
index 5c009df87..6473ba151 100644
--- a/src/plugins/platforms/qwayland-egl/CMakeLists.txt
+++ b/src/plugins/platforms/qwayland-egl/CMakeLists.txt
@@ -1,3 +1,6 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
# Generated from qwayland-egl.pro.
#####################################################################
@@ -7,24 +10,14 @@ qt_find_package(EGL) # special case
qt_internal_add_plugin(QWaylandEglPlatformIntegrationPlugin
OUTPUT_NAME qwayland-egl
- TYPE platforms
+ PLUGIN_TYPE platforms
SOURCES
- ../../../hardwareintegration/client/wayland-egl/qwaylandeglclientbufferintegration.cpp ../../../hardwareintegration/client/wayland-egl/qwaylandeglclientbufferintegration.h
- ../../../hardwareintegration/client/wayland-egl/qwaylandeglinclude.h
- ../../../hardwareintegration/client/wayland-egl/qwaylandeglwindow.cpp ../../../hardwareintegration/client/wayland-egl/qwaylandeglwindow.h
- ../../../hardwareintegration/client/wayland-egl/qwaylandglcontext.cpp ../../../hardwareintegration/client/wayland-egl/qwaylandglcontext.h
main.cpp
- INCLUDE_DIRECTORIES
- ../../../hardwareintegration/client/wayland-egl
- PUBLIC_LIBRARIES
- ${CMAKE_DL_LIBS}
- EGL::EGL
+ LIBRARIES
Qt::Core
Qt::Gui
- Qt::OpenGLPrivate
Qt::WaylandClientPrivate
- Wayland::Client
- Wayland::Egl
+ Qt::WaylandEglClientHwIntegrationPrivate
)
#### Keys ignored in scope 1:.:.:qwayland-egl.pro:<TRUE>: