summaryrefslogtreecommitdiffstats
path: root/src/plugins/shellintegration/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/shellintegration/CMakeLists.txt')
-rw-r--r--src/plugins/shellintegration/CMakeLists.txt11
1 files changed, 6 insertions, 5 deletions
diff --git a/src/plugins/shellintegration/CMakeLists.txt b/src/plugins/shellintegration/CMakeLists.txt
index 03364328c..35967baf1 100644
--- a/src/plugins/shellintegration/CMakeLists.txt
+++ b/src/plugins/shellintegration/CMakeLists.txt
@@ -1,3 +1,6 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
# Generated from shellintegration.pro.
if(QT_FEATURE_wayland_client_fullscreen_shell_v1)
@@ -12,9 +15,7 @@ endif()
if(QT_FEATURE_wayland_client_xdg_shell)
add_subdirectory(xdg-shell)
endif()
-if(QT_FEATURE_wayland_client_xdg_shell_v5)
- add_subdirectory(xdg-shell-v5)
-endif()
-if(QT_FEATURE_wayland_client_xdg_shell_v6)
- add_subdirectory(xdg-shell-v6)
+
+if(QT_FEATURE_wayland_client_qt_shell)
+ add_subdirectory(qt-shell)
endif()