summaryrefslogtreecommitdiffstats
path: root/src/plugins/shellintegration/wl-shell/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/shellintegration/wl-shell/CMakeLists.txt')
-rw-r--r--src/plugins/shellintegration/wl-shell/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/plugins/shellintegration/wl-shell/CMakeLists.txt b/src/plugins/shellintegration/wl-shell/CMakeLists.txt
index 6b9ff55fe..09b076d00 100644
--- a/src/plugins/shellintegration/wl-shell/CMakeLists.txt
+++ b/src/plugins/shellintegration/wl-shell/CMakeLists.txt
@@ -1,3 +1,6 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
# Generated from wl-shell.pro.
#####################################################################
@@ -14,6 +17,9 @@ qt_internal_add_module(WlShellIntegrationPrivate
Qt::GuiPrivate
Qt::WaylandClientPrivate
Wayland::Client
+ PRIVATE_HEADER_FILTERS
+ "^qwayland-.*\.h|^wayland-.*-protocol\.h"
+ NO_GENERATE_CPP_EXPORTS
)
qt6_generate_wayland_protocol_client_sources(WlShellIntegrationPrivate