summaryrefslogtreecommitdiffstats
path: root/src/plugins/shellintegration/wl-shell/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/shellintegration/wl-shell/CMakeLists.txt')
-rw-r--r--src/plugins/shellintegration/wl-shell/CMakeLists.txt46
1 files changed, 34 insertions, 12 deletions
diff --git a/src/plugins/shellintegration/wl-shell/CMakeLists.txt b/src/plugins/shellintegration/wl-shell/CMakeLists.txt
index 56cc5b853..09b076d00 100644
--- a/src/plugins/shellintegration/wl-shell/CMakeLists.txt
+++ b/src/plugins/shellintegration/wl-shell/CMakeLists.txt
@@ -1,36 +1,58 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
# Generated from wl-shell.pro.
#####################################################################
-## QWaylandWlShellIntegrationPlugin Plugin:
+## WlShellIntegrationPrivate Module:
#####################################################################
-qt_internal_add_plugin(QWaylandWlShellIntegrationPlugin
- OUTPUT_NAME wl-shell
- TYPE wayland-shell-integration
+qt_internal_add_module(WlShellIntegrationPrivate
+ CONFIG_MODULE_NAME wl_shell_integration
+ INTERNAL_MODULE
SOURCES
- main.cpp
qwaylandwlshellintegration.cpp qwaylandwlshellintegration_p.h
qwaylandwlshellsurface.cpp qwaylandwlshellsurface_p.h
- PUBLIC_LIBRARIES
- Qt::Core
- Qt::Gui
+ LIBRARIES
Qt::GuiPrivate
Qt::WaylandClientPrivate
Wayland::Client
+ PRIVATE_HEADER_FILTERS
+ "^qwayland-.*\.h|^wayland-.*-protocol\.h"
+ NO_GENERATE_CPP_EXPORTS
)
-qt6_generate_wayland_protocol_client_sources(QWaylandWlShellIntegrationPlugin
+qt6_generate_wayland_protocol_client_sources(WlShellIntegrationPrivate
+ # this is just a helper module and still part of the QtWaylandClient build
+ __QT_INTERNAL_WAYLAND_INCLUDE_DIR QtWaylandClient/private
FILES
${CMAKE_CURRENT_SOURCE_DIR}/../../../3rdparty/protocol/wayland.xml
)
-#### Keys ignored in scope 1:.:.:wl-shell.pro:<TRUE>:
-# OTHER_FILES = "wl-shell.json"
+#### Keys ignored in scope 2:.:.:wl-shell-integration.pro:<TRUE>:
+# MODULE = "wl_shell_integration"
## Scopes:
#####################################################################
-qt_internal_extend_target(QWaylandWlShellIntegrationPlugin CONDITION QT_FEATURE_xkbcommon
+qt_internal_extend_target(WlShellIntegrationPrivate CONDITION QT_FEATURE_xkbcommon
LIBRARIES
XKB::XKB
)
+#####################################################################
+## QWaylandWlShellIntegrationPlugin Plugin:
+#####################################################################
+
+qt_internal_add_plugin(QWaylandWlShellIntegrationPlugin
+ OUTPUT_NAME wl-shell-plugin
+ PLUGIN_TYPE wayland-shell-integration
+ SOURCES
+ main.cpp
+ LIBRARIES
+ Qt::GuiPrivate
+ Qt::WaylandClientPrivate
+ Qt::WlShellIntegrationPrivate
+)
+
+#### Keys ignored in scope 4:.:.:wl-shell-plugin.pro:<TRUE>:
+# OTHER_FILES = "wl-shell.json"