summaryrefslogtreecommitdiffstats
path: root/src/plugins/shellintegration/xdg-shell/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/shellintegration/xdg-shell/CMakeLists.txt')
-rw-r--r--src/plugins/shellintegration/xdg-shell/CMakeLists.txt13
1 files changed, 11 insertions, 2 deletions
diff --git a/src/plugins/shellintegration/xdg-shell/CMakeLists.txt b/src/plugins/shellintegration/xdg-shell/CMakeLists.txt
index 88a78df7f..af5a97fee 100644
--- a/src/plugins/shellintegration/xdg-shell/CMakeLists.txt
+++ b/src/plugins/shellintegration/xdg-shell/CMakeLists.txt
@@ -1,3 +1,6 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
# Generated from xdg-shell.pro.
#####################################################################
@@ -6,13 +9,16 @@
qt_internal_add_plugin(QWaylandXdgShellIntegrationPlugin
OUTPUT_NAME xdg-shell
- TYPE wayland-shell-integration
+ PLUGIN_TYPE wayland-shell-integration
SOURCES
main.cpp
qwaylandxdgdecorationv1.cpp qwaylandxdgdecorationv1_p.h
+ qwaylandxdgactivationv1.cpp qwaylandxdgactivationv1_p.h
qwaylandxdgshell.cpp qwaylandxdgshell_p.h
qwaylandxdgshellintegration.cpp qwaylandxdgshellintegration_p.h
- PUBLIC_LIBRARIES
+ qwaylandxdgexporterv2.cpp qwaylandxdgexporterv2_p.h
+ qwaylandxdgdialogv1.cpp qwaylandxdgdialogv1_p.h
+ LIBRARIES
Qt::Core
Qt::Gui
Qt::GuiPrivate
@@ -24,6 +30,9 @@ qt6_generate_wayland_protocol_client_sources(QWaylandXdgShellIntegrationPlugin
FILES
${CMAKE_CURRENT_SOURCE_DIR}/../../../3rdparty/protocol/xdg-decoration-unstable-v1.xml
${CMAKE_CURRENT_SOURCE_DIR}/../../../3rdparty/protocol/xdg-shell.xml
+ ${CMAKE_CURRENT_SOURCE_DIR}/../../../3rdparty/protocol/xdg-activation-v1.xml
+ ${CMAKE_CURRENT_SOURCE_DIR}/../../../3rdparty/protocol/xdg-foreign-unstable-v2.xml
+ ${CMAKE_CURRENT_SOURCE_DIR}/../../../3rdparty/protocol/xdg-dialog-v1.xml
)
#### Keys ignored in scope 1:.:.:xdg-shell.pro:<TRUE>: