summaryrefslogtreecommitdiffstats
path: root/tests/auto/client/client/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/client/client/CMakeLists.txt')
-rw-r--r--tests/auto/client/client/CMakeLists.txt33
1 files changed, 5 insertions, 28 deletions
diff --git a/tests/auto/client/client/CMakeLists.txt b/tests/auto/client/client/CMakeLists.txt
index 86eb420e5..c6495eb6b 100644
--- a/tests/auto/client/client/CMakeLists.txt
+++ b/tests/auto/client/client/CMakeLists.txt
@@ -1,3 +1,6 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
# Generated from client.pro.
#####################################################################
@@ -6,35 +9,9 @@
qt_internal_add_test(tst_client
SOURCES
- ../shared_old/mockcompositor.cpp ../shared_old/mockcompositor.h
- ../shared_old/mockfullscreenshellv1.cpp ../shared_old/mockfullscreenshellv1.h
- ../shared_old/mockinput.cpp ../shared_old/mockinput.h
- ../shared_old/mockiviapplication.cpp ../shared_old/mockiviapplication.h
- ../shared_old/mockoutput.cpp ../shared_old/mockoutput.h
- ../shared_old/mockregion.cpp ../shared_old/mockregion.h
- ../shared_old/mocksurface.cpp ../shared_old/mocksurface.h
- ../shared_old/mockwlshell.cpp ../shared_old/mockwlshell.h
- ../shared_old/mockxdgshellv6.cpp ../shared_old/mockxdgshellv6.h
tst_client.cpp
- INCLUDE_DIRECTORIES
- ../shared_old
- PUBLIC_LIBRARIES
- Qt::CorePrivate
- Qt::Gui
- Qt::GuiPrivate
- Qt::OpenGL
- Qt::WaylandClientPrivate
- Wayland::Client
- Wayland::Server
- Threads::Threads # special case
-)
-
-qt6_generate_wayland_protocol_server_sources(tst_client
- FILES
- ${CMAKE_CURRENT_SOURCE_DIR}/../../../../src/3rdparty/protocol/fullscreen-shell-unstable-v1.xml
- ${CMAKE_CURRENT_SOURCE_DIR}/../../../../src/3rdparty/protocol/ivi-application.xml
- ${CMAKE_CURRENT_SOURCE_DIR}/../../../../src/3rdparty/protocol/wayland.xml
- ${CMAKE_CURRENT_SOURCE_DIR}/../../../../src/3rdparty/protocol/xdg-shell-unstable-v6.xml
+ LIBRARIES
+ SharedClientTest
)
#### Keys ignored in scope 1:.:.:client.pro:<TRUE>: