summaryrefslogtreecommitdiffstats
path: root/tests/auto/client/seatv4/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/client/seatv4/CMakeLists.txt')
-rw-r--r--tests/auto/client/seatv4/CMakeLists.txt30
1 files changed, 6 insertions, 24 deletions
diff --git a/tests/auto/client/seatv4/CMakeLists.txt b/tests/auto/client/seatv4/CMakeLists.txt
index f4eb28b84..c4e3ecba1 100644
--- a/tests/auto/client/seatv4/CMakeLists.txt
+++ b/tests/auto/client/seatv4/CMakeLists.txt
@@ -1,3 +1,6 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
# Generated from seatv4.pro.
#####################################################################
@@ -6,37 +9,16 @@
qt_internal_add_test(tst_seatv4
SOURCES
- ../shared/corecompositor.cpp ../shared/corecompositor.h
- ../shared/coreprotocol.cpp ../shared/coreprotocol.h
- ../shared/datadevice.cpp ../shared/datadevice.h
- ../shared/mockcompositor.cpp ../shared/mockcompositor.h
- ../shared/textinput.cpp ../shared/textinput.h
- ../shared/xdgoutputv1.cpp ../shared/xdgoutputv1.h
- ../shared/xdgshell.cpp ../shared/xdgshell.h
tst_seatv4.cpp
- INCLUDE_DIRECTORIES
- ../shared
- PUBLIC_LIBRARIES
- Qt::Gui
- Qt::OpenGL
- Qt::WaylandClientPrivate
- Wayland::Server
- Threads::Threads # special case
-)
-
-qt6_generate_wayland_protocol_server_sources(tst_seatv4
- FILES
- ${CMAKE_CURRENT_SOURCE_DIR}/../shared/../../../../src/3rdparty/protocol/text-input-unstable-v2.xml
- ${CMAKE_CURRENT_SOURCE_DIR}/../shared/../../../../src/3rdparty/protocol/wayland.xml
- ${CMAKE_CURRENT_SOURCE_DIR}/../shared/../../../../src/3rdparty/protocol/xdg-output-unstable-v1.xml
- ${CMAKE_CURRENT_SOURCE_DIR}/../shared/../../../../src/3rdparty/protocol/xdg-shell.xml
+ LIBRARIES
+ SharedClientTest
)
## Scopes:
#####################################################################
qt_internal_extend_target(tst_seatv4 CONDITION QT_FEATURE_cursor
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::GuiPrivate
Wayland::Cursor
)