summaryrefslogtreecommitdiffstats
path: root/tests/auto/client/shared/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/client/shared/CMakeLists.txt')
-rw-r--r--tests/auto/client/shared/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/tests/auto/client/shared/CMakeLists.txt b/tests/auto/client/shared/CMakeLists.txt
index c465ea1b5..530acf264 100644
--- a/tests/auto/client/shared/CMakeLists.txt
+++ b/tests/auto/client/shared/CMakeLists.txt
@@ -7,6 +7,7 @@ add_library(SharedClientTest
corecompositor.cpp corecompositor.h
coreprotocol.cpp coreprotocol.h
datadevice.cpp datadevice.h
+ fullscreenshellv1.cpp fullscreenshellv1.h
mockcompositor.cpp mockcompositor.h
textinput.cpp textinput.h
xdgoutputv1.cpp xdgoutputv1.h
@@ -17,6 +18,7 @@ set_property(TARGET SharedClientTest PROPERTY AUTOMOC ON)
qt6_generate_wayland_protocol_server_sources(SharedClientTest
FILES
+ ${PROJECT_SOURCE_DIR}/src/3rdparty/protocol/fullscreen-shell-unstable-v1.xml
${PROJECT_SOURCE_DIR}/src/3rdparty/protocol/wp-primary-selection-unstable-v1.xml
${PROJECT_SOURCE_DIR}/src/3rdparty/protocol/tablet-unstable-v2.xml
${PROJECT_SOURCE_DIR}/src/3rdparty/protocol/text-input-unstable-v2.xml