summaryrefslogtreecommitdiffstats
path: root/tests/auto/client/xdgoutput/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/client/xdgoutput/CMakeLists.txt')
-rw-r--r--tests/auto/client/xdgoutput/CMakeLists.txt28
1 files changed, 5 insertions, 23 deletions
diff --git a/tests/auto/client/xdgoutput/CMakeLists.txt b/tests/auto/client/xdgoutput/CMakeLists.txt
index 37dee4e46..123a78f8e 100644
--- a/tests/auto/client/xdgoutput/CMakeLists.txt
+++ b/tests/auto/client/xdgoutput/CMakeLists.txt
@@ -1,3 +1,6 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
# Generated from xdgoutput.pro.
#####################################################################
@@ -6,28 +9,7 @@
qt_internal_add_test(tst_xdgoutput
SOURCES
- ../shared/corecompositor.cpp ../shared/corecompositor.h
- ../shared/coreprotocol.cpp ../shared/coreprotocol.h
- ../shared/datadevice.cpp ../shared/datadevice.h
- ../shared/mockcompositor.cpp ../shared/mockcompositor.h
- ../shared/textinput.cpp ../shared/textinput.h
- ../shared/xdgoutputv1.cpp ../shared/xdgoutputv1.h
- ../shared/xdgshell.cpp ../shared/xdgshell.h
tst_xdgoutput.cpp
- INCLUDE_DIRECTORIES
- ../shared
- PUBLIC_LIBRARIES
- Qt::Gui
- Qt::OpenGL
- Qt::WaylandClientPrivate
- Wayland::Server
- Threads::Threads # special case
-)
-
-qt6_generate_wayland_protocol_server_sources(tst_xdgoutput
- FILES
- ${CMAKE_CURRENT_SOURCE_DIR}/../shared/../../../../src/3rdparty/protocol/text-input-unstable-v2.xml
- ${CMAKE_CURRENT_SOURCE_DIR}/../shared/../../../../src/3rdparty/protocol/wayland.xml
- ${CMAKE_CURRENT_SOURCE_DIR}/../shared/../../../../src/3rdparty/protocol/xdg-output-unstable-v1.xml
- ${CMAKE_CURRENT_SOURCE_DIR}/../shared/../../../../src/3rdparty/protocol/xdg-shell.xml
+ LIBRARIES
+ SharedClientTest
)