summaryrefslogtreecommitdiffstats
path: root/tests/auto/cmake/test_waylandclient/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/cmake/test_waylandclient/CMakeLists.txt')
-rw-r--r--tests/auto/cmake/test_waylandclient/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/tests/auto/cmake/test_waylandclient/CMakeLists.txt b/tests/auto/cmake/test_waylandclient/CMakeLists.txt
new file mode 100644
index 000000000..3788a4927
--- /dev/null
+++ b/tests/auto/cmake/test_waylandclient/CMakeLists.txt
@@ -0,0 +1,12 @@
+project(test_plugins)
+
+cmake_minimum_required(VERSION 2.8)
+cmake_policy(SET CMP0056 NEW)
+
+find_package(Qt5WaylandClient REQUIRED)
+
+set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${Qt5Core_EXECUTABLE_COMPILE_FLAGS}")
+
+include_directories(${Qt5WaylandClient_PRIVATE_INCLUDE_DIRS})
+add_executable(test_waylandclient_exe main.cpp)
+target_link_libraries(test_waylandclient_exe Qt5::WaylandClient)