summaryrefslogtreecommitdiffstats
path: root/tests/manual/texture-sharing-2/custom-compositor/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/manual/texture-sharing-2/custom-compositor/CMakeLists.txt')
-rw-r--r--tests/manual/texture-sharing-2/custom-compositor/CMakeLists.txt52
1 files changed, 11 insertions, 41 deletions
diff --git a/tests/manual/texture-sharing-2/custom-compositor/CMakeLists.txt b/tests/manual/texture-sharing-2/custom-compositor/CMakeLists.txt
index c8d9839c7..1a6c1494a 100644
--- a/tests/manual/texture-sharing-2/custom-compositor/CMakeLists.txt
+++ b/tests/manual/texture-sharing-2/custom-compositor/CMakeLists.txt
@@ -1,37 +1,13 @@
-# Generated from custom-compositor.pro.
-
-cmake_minimum_required(VERSION 3.16)
-project(texture-sharing-custom-compositor LANGUAGES CXX)
-
-set(CMAKE_INCLUDE_CURRENT_DIR ON)
-
-set(CMAKE_AUTOMOC ON)
-set(CMAKE_AUTORCC ON)
-set(CMAKE_AUTOUIC ON)
-
-if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
-endif()
-
-set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/wayland/texture-sharing/custom-compositor")
-
-find_package(Qt6 COMPONENTS Core)
-find_package(Qt6 COMPONENTS Gui)
-find_package(Qt6 COMPONENTS Qml)
-find_package(Qt6 COMPONENTS WaylandCompositor)
-
-qt_add_executable(texture-sharing-custom-compositor
- main.cpp
-)
-set_target_properties(texture-sharing-custom-compositor PROPERTIES
- WIN32_EXECUTABLE TRUE
- MACOSX_BUNDLE TRUE
-)
-target_link_libraries(texture-sharing-custom-compositor PUBLIC
- Qt::Core
- Qt::Gui
- Qt::Qml
- Qt::WaylandCompositorPrivate
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+qt_internal_add_manual_test(texture-sharing-custom-compositor
+ GUI
+ SOURCES
+ main.cpp
+ LIBRARIES
+ Qt::Qml
+ Qt::WaylandCompositorPrivate
)
@@ -44,15 +20,9 @@ set(compositor_resource_files
"qml/main.qml"
)
-qt6_add_resources(texture-sharing-custom-compositor "compositor"
+qt_internal_add_resource(texture-sharing-custom-compositor "compositor"
PREFIX
"/"
FILES
${compositor_resource_files}
)
-
-install(TARGETS texture-sharing-custom-compositor
- RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
- BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
- LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
-)