aboutsummaryrefslogtreecommitdiffstats
path: root/examples/webchannel/standalone/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/webchannel/standalone/CMakeLists.txt')
-rw-r--r--examples/webchannel/standalone/CMakeLists.txt18
1 files changed, 5 insertions, 13 deletions
diff --git a/examples/webchannel/standalone/CMakeLists.txt b/examples/webchannel/standalone/CMakeLists.txt
index 420f06e..213c97b 100644
--- a/examples/webchannel/standalone/CMakeLists.txt
+++ b/examples/webchannel/standalone/CMakeLists.txt
@@ -1,25 +1,16 @@
-# Generated from standalone.pro.
-
cmake_minimum_required(VERSION 3.16)
project(standalone LANGUAGES CXX)
-set(CMAKE_INCLUDE_CURRENT_DIR ON)
-
set(CMAKE_AUTOMOC ON)
-set(CMAKE_AUTORCC ON)
set(CMAKE_AUTOUIC ON)
if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
+ set(INSTALL_EXAMPLESDIR "examples")
endif()
set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/webchannel/standalone")
-find_package(Qt6 COMPONENTS Core)
-find_package(Qt6 COMPONENTS Gui)
-find_package(Qt6 COMPONENTS WebChannel)
-find_package(Qt6 COMPONENTS Widgets)
-find_package(Qt6 COMPONENTS WebSockets)
+find_package(Qt6 REQUIRED COMPONENTS Core Gui WebChannel WebSockets Widgets)
qt_add_executable(standalone
../shared/websocketclientwrapper.cpp ../shared/websocketclientwrapper.h
@@ -28,16 +19,17 @@ qt_add_executable(standalone
dialog.cpp dialog.h dialog.ui
main.cpp
)
+
set_target_properties(standalone PROPERTIES
WIN32_EXECUTABLE TRUE
MACOSX_BUNDLE TRUE
)
-# special case begin
+
# pro2cmake generates invalid cmake syntax here
target_compile_definitions(standalone PUBLIC
"BUILD_DIR=\"${CMAKE_CURRENT_BINARY_DIR}\""
)
-# special case end
+
target_link_libraries(standalone PUBLIC
Qt::Core
Qt::Gui