summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndras Becsi <andras.becsi@theqtcompany.com>2015-04-24 11:18:53 +0200
committerAndras Becsi <andras.becsi@theqtcompany.com>2015-04-24 09:31:13 +0000
commitc7997c1d5668985e6d05dd2b83fbe89ead029d7c (patch)
tree0a85eb4613d477bee94a683e9eaa72e9f928879d
parentd4c80ea7dfb542e28d1268bb91fed7d34b92a6b2 (diff)
Partially revert "Fix QtCreator loading of qtwebengine.pro"
Changing the python print signature seems to cause problems on Windows, so revert it. Change-Id: I715f792b880a2269ec153bbc73b432c6a4e87cc5 Reviewed-by: Michael BrĂ¼ning <michael.bruning@theqtcompany.com>
-rwxr-xr-xtools/buildscripts/find-included-moc-files2
-rwxr-xr-xtools/buildscripts/find-mocables2
-rw-r--r--tools/qmake/mkspecs/features/functions.prf4
3 files changed, 4 insertions, 4 deletions
diff --git a/tools/buildscripts/find-included-moc-files b/tools/buildscripts/find-included-moc-files
index c7636029..e55f3824 100755
--- a/tools/buildscripts/find-included-moc-files
+++ b/tools/buildscripts/find-included-moc-files
@@ -10,4 +10,4 @@ for f in filter(os.path.isfile, sys.argv[1:]):
if m:
includedMocs.add(m.group(1))
for moc in includedMocs:
- print(moc)
+ print moc
diff --git a/tools/buildscripts/find-mocables b/tools/buildscripts/find-mocables
index 6c709399..7c383cfe 100755
--- a/tools/buildscripts/find-mocables
+++ b/tools/buildscripts/find-mocables
@@ -23,4 +23,4 @@ for f in filter(os.path.isfile, sys.argv[1:]):
if re.match(".*Q_OBJECT", line):
mocables.add(f)
for mocable in mocables:
- print(mocable)
+ print mocable
diff --git a/tools/qmake/mkspecs/features/functions.prf b/tools/qmake/mkspecs/features/functions.prf
index e1864f7b..ef0320da 100644
--- a/tools/qmake/mkspecs/features/functions.prf
+++ b/tools/qmake/mkspecs/features/functions.prf
@@ -22,8 +22,8 @@ defineTest(isPlatformSupported) {
}
defineTest(isPythonVersionSupported) {
- python_major_version = $$system('python -c "import sys; print(sys.version_info.major)"')
- python_minor_version = $$system('python -c "import sys; print(sys.version_info.minor)"')
+ python_major_version = $$system('python -c "import sys; print sys.version_info.major"')
+ python_minor_version = $$system('python -c "import sys; print sys.version_info.minor"')
lessThan(python_major_version, 3): greaterThan(python_major_version, 1): greaterThan(python_minor_version, 6): return(true)
skipBuild("Using Python version "$$python_major_version"."$$python_minor_version", but Python version 2 (2.7 or later) is required to build Qt WebEngine.")
return(false)