summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAllan Sandfeld Jensen <allan.jensen@qt.io>2017-03-03 16:31:08 +0100
committerAllan Sandfeld Jensen <allan.jensen@qt.io>2017-03-26 17:56:01 +0000
commit817c117cf89f15e1877107597c8daeff956fd1a6 (patch)
tree2bd6e6480ee96ca260dd648a497237f7a4d6171b
parentdd3163be45f68c9807d834d010e6d5b7f550e2b5 (diff)
Remove blacklists of old glib and gcc 4.8 debug builds
We never saw the same failure with gcc 4.8 debug builds with 55-based, and the other failure suspected to related turned out not to be and have been fixed. So try to re-enable gcc 4.8 debug builds, and other old platforms but explicitly disable gcc 4.9.1 which fails to compile Chromium. Change-Id: Ib0a8ac33aafbd12d31e374dfd23f056b4ba1adf0 Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Allan Sandfeld Jensen <allan.jensen@qt.io>
-rw-r--r--tools/qmake/mkspecs/features/configure.prf1
-rw-r--r--tools/qmake/mkspecs/features/functions.prf14
2 files changed, 6 insertions, 9 deletions
diff --git a/tools/qmake/mkspecs/features/configure.prf b/tools/qmake/mkspecs/features/configure.prf
index 260e0f6d..1c905df2 100644
--- a/tools/qmake/mkspecs/features/configure.prf
+++ b/tools/qmake/mkspecs/features/configure.prf
@@ -57,7 +57,6 @@ defineTest(runConfigure) {
}
qtConfig(glib) {
packagesExist("\'glib-2.0 >= 2.32.0\'"): WEBENGINE_CONFIG += use_glib
- else: skipBuild("System glib is too old (min. version 2.32).$${EOL}")
}
for(package, $$list($$REQUIRED_PACKAGES)) {
diff --git a/tools/qmake/mkspecs/features/functions.prf b/tools/qmake/mkspecs/features/functions.prf
index b4965129..1a1f3cf7 100644
--- a/tools/qmake/mkspecs/features/functions.prf
+++ b/tools/qmake/mkspecs/features/functions.prf
@@ -221,17 +221,15 @@ defineTest(isSanitizerLinuxClangVersionSupported) {
}
defineTest(isGCCVersionSupported) {
+ equals(QT_GCC_MAJOR_VERSION, 4):equals(QT_GCC_MINOR_VERSION, 9):lessThan(QT_GCC_PATCH_VERSION, 2) {
+ skipBuild("Gcc 4.9.1 fails to compile QtWebEngine, please use another gcc version.")
+ return(false)
+ }
# The below will work for gcc 4.7 and up and also match gcc 5
- CONFIG(release, debug|release): greaterThan(QT_GCC_MINOR_VERSION, 6):return(true)
+ greaterThan(QT_GCC_MINOR_VERSION, 6):return(true)
greaterThan(QT_GCC_MAJOR_VERSION, 4):return(true)
- # We need GCC 4.9 for debug builds because Skia handles SIMD inlines in headers poorly.
- greaterThan(QT_GCC_MINOR_VERSION, 8):return(true)
- CONFIG(debug, debug|release) {
- skipBuild("Using gcc version "$$QT_GCC_MAJOR_VERSION"."$$QT_GCC_MINOR_VERSION", but at least gcc version 4.9 is required to build debug versions of Qt WebEngine.")
- } else {
- skipBuild("Using gcc version "$$QT_GCC_MAJOR_VERSION"."$$QT_GCC_MINOR_VERSION", but at least gcc version 4.7 is required to build Qt WebEngine.")
- }
+ skipBuild("Using gcc version "$$QT_GCC_MAJOR_VERSION"."$$QT_GCC_MINOR_VERSION", but at least gcc version 4.7 is required to build Qt WebEngine.")
return(false)
}