summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichal Klocek <michal.klocek@qt.io>2021-06-25 12:39:08 +0200
committerQt Cherry-pick Bot <cherrypick_bot@qt-project.org>2021-06-30 12:08:28 +0000
commit94a1058bdb29f6ff911820563565193ea263929d (patch)
tree6b5c0dd79a6d68c7fb1ff1b89acef71de905b92b /CMakeLists.txt
parent670f928e4ff403b7b9acdf6468eaea642671df4d (diff)
Add implicit dependencies in case of topLevel build
Change-Id: Ic7a4096d06b05a62a01565d6e7aceac12dc73def Reviewed-by: Allan Sandfeld Jensen <allan.jensen@qt.io> (cherry picked from commit 7237c81bf20571fac2f898e7e29e7be386e3270a) Reviewed-by: Qt Cherry-pick Bot <cherrypick_bot@qt-project.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c54c76bac..dbd925dc0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -157,6 +157,11 @@ externalproject_add(libs
COMMAND ${CMAKE_COMMAND} -E remove_directory ../mkspecs
)
+# required for topLevel build
+add_implicit_dependencies(libs Core Gui Widgets Network OpenGL
+ OpenGLWidgets Quick QuickWidgets Qml PrintSupport WebChannel Positioning
+)
+
# Ensure the libs project is reconfigured if the root project is reconfigured, so that the
# correct CMake and qmake support files are used when building examples, rather than
# using the incomplete support files created by the root project.