summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllan Sandfeld Jensen <allan.jensen@qt.io>2021-06-15 13:46:59 +0200
committerAllan Sandfeld Jensen <allan.jensen@qt.io>2021-06-17 14:41:41 +0200
commitc8643e47b0ba8dc0f345c2feaabfa60e54f809c3 (patch)
tree580b465c8a577f57df64cfe221df506f64967568 /CMakeLists.txt
parent566a4df270911e1656efef5dbb16e4f95bf6ca8d (diff)
Fix clang-cl builds
Pick-to: 6.2 Change-Id: I57d3c057e076445f902da509655728cb20a4a18b Reviewed-by: Michal Klocek <michal.klocek@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e5e3d3613..16223007f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -88,6 +88,8 @@ if(NOT Gn_FOUND)
PREFIX gn
USES_TERMINAL_BUILD ON
CMAKE_ARGS -DCMAKE_BUILD_TYPE=Release
+ -DCMAKE_C_COMPILER=${CMAKE_C_COMPILER}
+ -DCMAKE_CXX_COMPILER=${CMAKE_CXX_COMPILER}
-DCMAKE_INSTALL_PREFIX:PATH=<INSTALL_DIR>
-DCMAKE_PREFIX_PATH:PATH=<INSTALL_DIR>
-DWEBENGINE_ROOT_BUILD_DIR=${CMAKE_CURRENT_BINARY_DIR}