summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2022-03-04 11:50:49 +0100
committerQt Cherry-pick Bot <cherrypick_bot@qt-project.org>2022-03-05 07:57:25 +0000
commiteb501f06d7813fd9c2d1df43b099c8f20088e8eb (patch)
treecef847b578f4dfbc21872ac7c9299f1326b80357 /CMakeLists.txt
parent545f262385fa1fdf84fa42e23e9ac87338a77778 (diff)
CMake: Fail gracefully when using an unsupported CMake version
Previously if qtwebengine was configured with a CMake version lower than 3.19, CMake would exit with a fatal error saying the version is too low. Now the CMake version check is delayed to the configure summary which changes the hard error into a build time warning instead, just like with all the other repo requirements. An additional cmake_minimum_required call is used to require all 3.19 behaviors (upgraded policies) once configure establishes that the CMake version is new enough. Change-Id: I03a20ae62ce2dcee23e5615241c6c97a86df4d2f Reviewed-by: Michal Klocek <michal.klocek@qt.io> (cherry picked from commit 0332065357a5f65bb43d113f99a7138d0bc65261) Reviewed-by: Qt Cherry-pick Bot <cherrypick_bot@qt-project.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b0a0c7ffb..649c8c885 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,4 +1,7 @@
-cmake_minimum_required(VERSION 3.19)
+# Require the Qt (not WebEngine) minimum supported CMake version.
+# Another WebEngine-specific version check will be done in configure.cmake
+# and reported in the configure summary.
+cmake_minimum_required(VERSION 3.16)
include(.cmake.conf)
include(ExternalProject)