summaryrefslogtreecommitdiffstats
path: root/mkspecs
diff options
context:
space:
mode:
authorAllan Sandfeld Jensen <allan.jensen@qt.io>2017-05-08 14:44:17 +0200
committerJani Heikkinen <jani.heikkinen@qt.io>2017-05-10 04:16:52 +0000
commit637beda0062ff65918823147830b52e29ae550a6 (patch)
treeb7d2ef4aa1c05dc4ba7ba4c0032544090ace638b /mkspecs
parent757d5b1cea0d3d70b97b31f331df9ada82f45d2d (diff)
Fix backwards compatibility
QtWebEngine supports building with last stable and last LTS Qt releases. Guard some 5.7-5.9 API from being used when not available, and reinstate the default features for 5.6 LTS builds. Change-Id: Ia288a49109d011a2bee883d4a2d38d994b497d59 Reviewed-by: Michael BrĂ¼ning <michael.bruning@qt.io>
Diffstat (limited to 'mkspecs')
-rw-r--r--mkspecs/features/configure.prf7
1 files changed, 6 insertions, 1 deletions
diff --git a/mkspecs/features/configure.prf b/mkspecs/features/configure.prf
index b293a5ef..f56f9a55 100644
--- a/mkspecs/features/configure.prf
+++ b/mkspecs/features/configure.prf
@@ -39,7 +39,12 @@ defineTest(runConfigure) {
qtConfig(system-icu): WEBENGINE_CONFIG += use_system_icu
else: WEBENGINE_CONFIG += use_bundled_icu
} else {
- cross_compile: WEBENGINE_CONFIG += embedded_build reduce_binary_size
+ # Feature defaults when building with Qt 5.6 LTS:
+ cross_compile {
+ WEBENGINE_CONFIG += embedded_build reduce_binary_size
+ } else {
+ WEBENGINE_CONFIG += use_spellchecker use_webrtc use_pepper_plugins use_printing use_pdf
+ }
}
isQtMinimum(5, 9) {
qtConfig(appstore-compliant): WEBENGINE_CONFIG += use_appstore_compliant_code