summaryrefslogtreecommitdiffstats
path: root/src/core/CMakeLists.txt
diff options
context:
space:
mode:
authorMichal Klocek <michal.klocek@qt.io>2021-02-04 17:12:08 +0100
committerMichal Klocek <michal.klocek@qt.io>2021-05-12 09:41:01 +0200
commitd240e6647d48a87db324973e649c2b0aea5a6857 (patch)
treeb8517474be153b5c4a631f08b9fb104a52cbb49a /src/core/CMakeLists.txt
parent5cf3eaa127b4633b46e1d6b70eb42253464bcd97 (diff)
Add BUILD.gn generation for the gn root and gn toolchain
Use simple templates. This will get own target in followup changes. Task-number: QTBUG-91760 Change-Id: I0b6991f7b54183aa9fb667cec5ad347f66c78b99 Reviewed-by: Allan Sandfeld Jensen <allan.jensen@qt.io> Reviewed-by: Joerg Bornemann <joerg.bornemann@qt.io>
Diffstat (limited to 'src/core/CMakeLists.txt')
-rw-r--r--src/core/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/core/CMakeLists.txt b/src/core/CMakeLists.txt
index cbec0aa13..bdb937e19 100644
--- a/src/core/CMakeLists.txt
+++ b/src/core/CMakeLists.txt
@@ -26,6 +26,10 @@ find_package(Python2 REQUIRED)
qt_build_repo_begin()
+include(generator.cmake)
+configure_file(${PROJECT_SOURCE_DIR}/configure/BUILD.toolchain.gn.in ${buildDir}/toolchain/BUILD.gn @ONLY)
+configure_file(${PROJECT_SOURCE_DIR}/configure/BUILD.root.gn.in ${buildDir}/BUILD.gn @ONLY)
+
get_target_property(gnCmd Gn::gn IMPORTED_LOCATION)
set(gnArg help)