summaryrefslogtreecommitdiffstats
path: root/src/core/api/CMakeLists.txt
diff options
context:
space:
mode:
authorMichal Klocek <michal.klocek@qt.io>2021-07-08 17:29:11 +0200
committerAllan Sandfeld Jensen <allan.jensen@qt.io>2021-07-22 10:15:54 +0200
commit5b651959002b7baff439e481bbf9f9076d7b60f3 (patch)
treecee038204b32971369a9793aec884c0172606798 /src/core/api/CMakeLists.txt
parentcd09335443a8e97d33b9a9e08da9f4e54faabf20 (diff)
Refactor cmake build
Add macros to share common cmake code blocks with QtPdf. Reconsider later to do proper scoping and change those to functions if make sense. Change-Id: I500acdba1415feab373a012dcf9a9ddedf33cfac (cherry picked from commit b3031066d17ef01802a4c9752f87675d6a4a1df5) Reviewed-by: Allan Sandfeld Jensen <allan.jensen@qt.io>
Diffstat (limited to 'src/core/api/CMakeLists.txt')
-rw-r--r--src/core/api/CMakeLists.txt3
1 files changed, 0 insertions, 3 deletions
diff --git a/src/core/api/CMakeLists.txt b/src/core/api/CMakeLists.txt
index afb00038a..e1fa62cd7 100644
--- a/src/core/api/CMakeLists.txt
+++ b/src/core/api/CMakeLists.txt
@@ -49,9 +49,6 @@ qt_internal_add_module(WebEngineCore
../../3rdparty/chromium
../../3rdparty/chromium/third_party/abseil-cpp
../../3rdparty/chromium/third_party/perfetto/include
- ${buildDir}/$<CONFIG>/gen
- ${buildDir}/$<CONFIG>/gen/third_party/perfetto
- ${buildDir}/$<CONFIG>/gen/third_party/perfetto/build_config
LIBRARIES
Qt::CorePrivate
Qt::GuiPrivate