summaryrefslogtreecommitdiffstats
path: root/src/core/api/CMakeLists.txt
diff options
context:
space:
mode:
authorSzabolcs David <davidsz@inf.u-szeged.hu>2021-06-03 01:37:37 +0200
committerSzabolcs David <davidsz@inf.u-szeged.hu>2021-06-03 14:05:22 +0200
commit4943d9801ccad59aef073374644fc991e49987e3 (patch)
tree4a4495c6a3391aa1bc4ad42d1548ff2f1bc9e46e /src/core/api/CMakeLists.txt
parent57140466f277a074b288a515b2bdfd26c8a3cbe3 (diff)
Drop printsupport dependency from core
Prevent linkage of core to widgets by moving printing API from QWebEnginePage to View and using QPagedPaintDevice (the QtGui ancestor of QPrinter) where it's needed. Change-Id: I6ea96edb495b0dcaaa584bbe72632fda025c18d3 Reviewed-by: Allan Sandfeld Jensen <allan.jensen@qt.io>
Diffstat (limited to 'src/core/api/CMakeLists.txt')
-rw-r--r--src/core/api/CMakeLists.txt6
1 files changed, 1 insertions, 5 deletions
diff --git a/src/core/api/CMakeLists.txt b/src/core/api/CMakeLists.txt
index bf2008ebd..4074bdb51 100644
--- a/src/core/api/CMakeLists.txt
+++ b/src/core/api/CMakeLists.txt
@@ -2,7 +2,7 @@ if(NOT DEFINED WEBENGINE_ROOT_SOURCE_DIR)
get_filename_component(WEBENGINE_ROOT_SOURCE_DIR "${CMAKE_CURRENT_LIST_DIR}/../../.." REALPATH)
endif()
find_package(Qt6 ${PROJECT_VERSION} REQUIRED COMPONENTS Gui Network OpenGL Quick)
-find_package(Qt6 ${PROJECT_VERSION} QUIET OPTIONAL_COMPONENTS PrintSupport WebChannel Positioning)
+find_package(Qt6 ${PROJECT_VERSION} QUIET OPTIONAL_COMPONENTS WebChannel Positioning)
include(${WEBENGINE_ROOT_SOURCE_DIR}/cmake/Functions.cmake)
get_configure_mode(configureMode)
@@ -65,10 +65,6 @@ qt_skip_warnings_are_errors(WebEngineCore)
make_install_only(WebEngineCore)
make_config_for_gn(WebEngineCore gn_config)
-qt_internal_extend_target(WebEngineCore CONDITION QT_FEATURE_webengine_printing_and_pdf
- PUBLIC_LIBRARIES
- Qt::PrintSupport
-)
qt_internal_extend_target(WebEngineCore CONDITION QT_FEATURE_webengine_webchannel
PUBLIC_LIBRARIES
Qt::WebChannel