summaryrefslogtreecommitdiffstats
path: root/src/core/api/CMakeLists.txt
diff options
context:
space:
mode:
authorMichal Klocek <michal.klocek@qt.io>2021-05-25 13:13:36 +0200
committerMichal Klocek <michal.klocek@qt.io>2021-05-25 14:40:56 +0000
commitf71472d37e93a54be78c91ae1770204a4de273ea (patch)
treefc5cf22b9d86cd7c93ac3e07a8cd014f8eacc2f4 /src/core/api/CMakeLists.txt
parent7bfc8458499897842caf2aa6b2e333e18a02ed21 (diff)
Add missing dependecies, update shas
Include WebChannel,Positioning cmake packages into WebEngineQuick and WebEngineWidgets. WebEngineCore depends on it so this should be pick up automatically, but in the case of clean build and due to how things work in cmake this is required otherwise linker genex will complain. Change-Id: I54fe8ffdb824e1fd0c0dcdfbbb43b1bcf06411bb Reviewed-by: Allan Sandfeld Jensen <allan.jensen@qt.io>
Diffstat (limited to 'src/core/api/CMakeLists.txt')
-rw-r--r--src/core/api/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/core/api/CMakeLists.txt b/src/core/api/CMakeLists.txt
index 3ee45af0f..5df3ba7b9 100644
--- a/src/core/api/CMakeLists.txt
+++ b/src/core/api/CMakeLists.txt
@@ -2,7 +2,7 @@ if(NOT DEFINED WEBENGINE_ROOT_SOURCE_DIR)
get_filename_component(WEBENGINE_ROOT_SOURCE_DIR "${CMAKE_CURRENT_LIST_DIR}/../../.." REALPATH)
endif()
find_package(Qt6 ${PROJECT_VERSION} REQUIRED COMPONENTS Gui Network OpenGL Quick)
-find_package(Qt6 ${PROJECT_VERSION} QUIET OPTIONAL_COMPONENTS PrintSupport WebChannel)
+find_package(Qt6 ${PROJECT_VERSION} QUIET OPTIONAL_COMPONENTS PrintSupport WebChannel Positioning)
include(${WEBENGINE_ROOT_SOURCE_DIR}/cmake/Functions.cmake)
get_configure_mode(configureMode)
@@ -72,3 +72,7 @@ qt_internal_extend_target(WebEngineCore CONDITION QT_FEATURE_webengine_webchanne
PUBLIC_LIBRARIES
Qt::WebChannel
)
+qt_internal_extend_target(WebEngineCore CONDITION QT_FEATURE_webengine_geolocation
+ PUBLIC_LIBRARIES
+ Qt::Positioning
+)