summaryrefslogtreecommitdiffstats
path: root/src/process/CMakeLists.txt
diff options
context:
space:
mode:
authorMichal Klocek <michal.klocek@qt.io>2021-02-05 11:44:04 +0100
committerMichal Klocek <michal.klocek@qt.io>2021-05-19 17:52:21 +0200
commit92dce39f771a75bf889ef780a1f631c43ddc502f (patch)
treef7de73f0b0cda5fe15c8968c3d2acfd04be90152 /src/process/CMakeLists.txt
parent85e7fa7f9a002e7c0708af7a99d165a23753ecf4 (diff)
Add QtWebEngineCore module cmake build
Create QtWebEngineCore, QtWebEngineProcess and drive headers sync from the libs project. Main project build should not generate any header files, since the logic in qtbase assumes fixed QT_BUILD_DIR, which is by default CMAKE_BINARY_DIR for prefix builds. Drive all syncqt calls from the libs project and leave the main build just for the feature evolution and the build summary reporting. This fixes header installation issues, however this patch requires also sync.profile update which is done later, to keep the qmake build still functional. Note this patch only adds debug builds for linux. Task-number: QTBUG-91760 Change-Id: I516c26206baa1cf6b966629a694dadce7f79dbec Reviewed-by: Allan Sandfeld Jensen <allan.jensen@qt.io>
Diffstat (limited to 'src/process/CMakeLists.txt')
-rw-r--r--src/process/CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/src/process/CMakeLists.txt b/src/process/CMakeLists.txt
new file mode 100644
index 000000000..a59901432
--- /dev/null
+++ b/src/process/CMakeLists.txt
@@ -0,0 +1,20 @@
+find_package(Qt6 COMPONENTS Gui)
+
+get_target_property(qtWebEngineProcessName WebEngineCore QTWEBENGINEPROCESS_NAME)
+
+qt_internal_add_executable(${qtWebEngineProcessName} SOURCES main.cpp)
+
+target_link_libraries(${qtWebEngineProcessName}
+ PUBLIC
+ Qt::Gui
+ Qt::WebEngineCore
+ PRIVATE
+ Qt::CorePrivate
+ Qt::WebEngineCorePrivate
+)
+
+target_include_directories(${qtWebEngineProcessName} PRIVATE ../core)
+
+install(TARGETS ${qtWebEngineProcessName} RUNTIME DESTINATION "${INSTALL_LIBEXECDIR}")
+
+make_install_only(${qtWebEngineProcessName})