summaryrefslogtreecommitdiffstats
path: root/src/process/CMakeLists.txt
diff options
context:
space:
mode:
authorMichal Klocek <michal.klocek@qt.io>2021-03-23 10:58:26 +0100
committerMichal Klocek <michal.klocek@qt.io>2021-05-22 14:10:19 +0200
commite6a7c6548f15cb158c1a5a2ac97fadaecb54f1ee (patch)
tree7d50d6df4904590e6fa2edafd78ffb8ac439d2e8 /src/process/CMakeLists.txt
parent6d6037be24bcbff5efada34ed39331c7c8b28f3b (diff)
Add windows to the cmake build
Fix cmake for windows builds and add QtWebEngineSandbox target. Task-number: QTBUG-91760 Change-Id: If962a81ddfb509d104ad8ffbfbf34f1150ae82ce Reviewed-by: Allan Sandfeld Jensen <allan.jensen@qt.io>
Diffstat (limited to 'src/process/CMakeLists.txt')
-rw-r--r--src/process/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/process/CMakeLists.txt b/src/process/CMakeLists.txt
index 7f1b40b90..3b0ee588f 100644
--- a/src/process/CMakeLists.txt
+++ b/src/process/CMakeLists.txt
@@ -10,6 +10,11 @@ get_target_property(isFramework WebEngineCore FRAMEWORK)
qt_internal_add_executable(${qtWebEngineProcessName} SOURCES main.cpp)
+if(WIN32)
+ target_sources(${qtWebEngineProcessName} PRIVATE support_win.cpp)
+ target_link_libraries(${qtWebEngineProcessName} PRIVATE WebEngineCoreSandbox)
+endif()
+
target_link_libraries(${qtWebEngineProcessName}
PUBLIC
Qt::Gui