summaryrefslogtreecommitdiffstats
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorPeter Varga <pvarga@inf.u-szeged.hu>2021-05-26 17:07:52 +0200
committerPeter Varga <pvarga@inf.u-szeged.hu>2021-05-28 09:21:44 +0200
commitb4ff1333677dc1c037b5ff5e5101016bd6a53469 (patch)
tree32093f0fdd2da7487569356e0380291b38959947 /tests/CMakeLists.txt
parent061c8adf127035dbfca39f2ce617e4e01afa8fed (diff)
Use fixed qt_add_resource BASE argument
Task-number: QTBUG-86726 Change-Id: I33ec2a73254d9b44de83f4f5491f372b4bb9959b Reviewed-by: Joerg Bornemann <joerg.bornemann@qt.io>
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index d334d49f1..e7b2008d1 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -9,6 +9,9 @@ if(NOT QT_BUILD_STANDALONE_TESTS)
HOMEPAGE_URL "https://qt.io/"
LANGUAGES CXX C
)
+
+ # Make sure we use the fixed BASE argument of qt_add_resource.
+ set(QT_USE_FIXED_QT_ADD_RESOURCE_BASE TRUE)
endif()
find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core)