summaryrefslogtreecommitdiffstats
path: root/tests/auto/pdf/CMakeLists.txt
diff options
context:
space:
mode:
authorShawn Rutledge <shawn.rutledge@qt.io>2024-03-21 14:28:07 -0700
committerShawn Rutledge <shawn.rutledge@qt.io>2024-03-24 16:11:10 -0700
commit832484634fc714ac3d5a54d33df5e3de13f75a40 (patch)
tree5029f53bcd1af15a3b91cdc49595b4f2c10bf499 /tests/auto/pdf/CMakeLists.txt
parent5642f33e17aa82fd361b972cd8ac88ba83604273 (diff)
Get tst_QPdfSearchModel working; check search results in rotated text
API has changed since b6dd845ec4a6bfb6b620686681e20d38a2f24101, and this test wasn't included in CMakeLists so we haven't been running it. Now it checks search result rectangle bounds. The new test PDFs are from the pdfium repository https://pdfium.googlesource.com/pdfium and include different kinds of transforms (the Tm command apparently). Task-number: QTBUG-120764 Change-Id: I25cf5944dd227dd4d2c70cbbac470d1d0fcc181a Reviewed-by: Axel Spoerl <axel.spoerl@qt.io> (cherry picked from commit f99e5ccf03e1b8fa3dd9725cbd9992850b9e4159) Reviewed-by: Shawn Rutledge <shawn.rutledge@qt.io>
Diffstat (limited to 'tests/auto/pdf/CMakeLists.txt')
-rw-r--r--tests/auto/pdf/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/auto/pdf/CMakeLists.txt b/tests/auto/pdf/CMakeLists.txt
index 2f3f73961..205bd24d0 100644
--- a/tests/auto/pdf/CMakeLists.txt
+++ b/tests/auto/pdf/CMakeLists.txt
@@ -6,6 +6,7 @@ if (TARGET Qt::PdfWidgets)
add_subdirectory(qpdfpagenavigator)
endif()
add_subdirectory(qpdfpagerenderer)
+add_subdirectory(qpdfsearchmodel)
if(TARGET Qt::PrintSupport)
add_subdirectory(qpdfdocument)
endif()