summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a84f1ed58..4ce56974d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -110,6 +110,19 @@ externalproject_add(libs
CMAKE_ARGS ${libsCmakeArgs}
)
+if(QT_BUILD_EXAMPLES AND BUILD_SHARED_LIBS)
+ externalproject_add(examples
+ SOURCE_DIR ${CMAKE_CURRENT_LIST_DIR}/examples
+ BINARY_DIR ${CMAKE_CURRENT_BINARY_DIR}/examples
+ PREFIX examples
+ USES_TERMINAL_BUILD ON
+ BUILD_ALWAYS TRUE
+ CMAKE_ARGS -DCMAKE_TOOLCHAIN_FILE=${CMAKE_TOOLCHAIN_FILE}
+ "${featureList}"
+ )
+ externalproject_add_stepdependencies(examples install libs)
+endif()
+
if(NOT Gn_FOUND)
externalproject_add_stepdependencies(libs install gn)
endif()