summaryrefslogtreecommitdiffstats
path: root/examples/webenginewidgets/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/webenginewidgets/CMakeLists.txt')
-rw-r--r--examples/webenginewidgets/CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/examples/webenginewidgets/CMakeLists.txt b/examples/webenginewidgets/CMakeLists.txt
new file mode 100644
index 000000000..651a01344
--- /dev/null
+++ b/examples/webenginewidgets/CMakeLists.txt
@@ -0,0 +1,21 @@
+add_subdirectory(minimal)
+add_subdirectory(contentmanipulation)
+add_subdirectory(cookiebrowser)
+add_subdirectory(notifications)
+add_subdirectory(simplebrowser)
+add_subdirectory(stylesheetbrowser)
+add_subdirectory(videoplayer)
+add_subdirectory(webui)
+if(QT_FEATURE_webengine_geolocation)
+ add_subdirectory(maps)
+endif()
+if(QT_FEATURE_webengine_webchannel)
+ add_subdirectory(markdowneditor)
+endif()
+if(QT_FEATURE_webengine_printing_and_pdf)
+ add_subdirectory(printme)
+ add_subdirectory(html2pdf)
+endif()
+if(QT_FEATURE_webengine_spellchecker AND NOT CMAKE_CROSSCOMPILING AND NOT QT_FEATURE_webengine_native_spellchecker)
+ add_subdirectory(spellchecker)
+endif()