summaryrefslogtreecommitdiffstats
path: root/src/core/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/core/CMakeLists.txt')
-rw-r--r--src/core/CMakeLists.txt13
1 files changed, 10 insertions, 3 deletions
diff --git a/src/core/CMakeLists.txt b/src/core/CMakeLists.txt
index b5c30d3b9..b881a316e 100644
--- a/src/core/CMakeLists.txt
+++ b/src/core/CMakeLists.txt
@@ -268,7 +268,7 @@ foreach(config ${configs})
if(${config} STREQUAL "Debug")
list(APPEND gnArgArg is_debug=true symbol_level=2)
- if(WIN32 AND NOT CLANG)
+ if(WIN32)
list(APPEND gnArgArg enable_iterator_debugging=true v8_optimized_debug=false)
endif()
elseif(${config} STREQUAL "Release")
@@ -336,9 +336,16 @@ foreach(config ${configs})
ARGS is_clang
CONDITION CLANG
)
- if(CLANG)
- list(APPEND gnArgArg clang_use_chrome_plugins=false)
+ if(CLANG AND NOT MACOS)
+ # For some reason this doesn't work for our macOS CIs
+ get_filename_component(clangBasePath ${CMAKE_CXX_COMPILER} DIRECTORY)
+ get_filename_component(clangBasePath ${clangBasePath} DIRECTORY)
+ list(APPEND gnArgArg
+ clang_base_path="${clangBasePath}"
+ clang_use_chrome_plugins=false
+ )
endif()
+
extend_gn_list(gnArgArg
ARGS use_gold
CONDITION QT_FEATURE_use_gold_linker