summaryrefslogtreecommitdiffstats
path: root/src/core/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/core/CMakeLists.txt')
-rw-r--r--src/core/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/core/CMakeLists.txt b/src/core/CMakeLists.txt
index 995c32475..783a3b03a 100644
--- a/src/core/CMakeLists.txt
+++ b/src/core/CMakeLists.txt
@@ -70,6 +70,10 @@ foreach(arch ${GN_ARCHITECTURES})
get_forward_declaration_macro(forwardDeclarationMacro)
get_target_property(qtWebEngineProcessName WebEngineCore QTWEBENGINEPROCESS_NAME)
+ if(QT_FEATURE_debug_and_release AND ("${config}" STREQUAL "Debug"))
+ set(qtWebEngineProcessName "${qtWebEngineProcessName}${CMAKE_DEBUG_POSTFIX}")
+ endif()
+
set(gnCxxCompileOptions "")
if("${CMAKE_CXX_COMPILER_ID}" STREQUAL "GNU")
# Silence warning in boringssl headers.