summaryrefslogtreecommitdiffstats
path: root/src/core/tools/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/core/tools/CMakeLists.txt')
-rw-r--r--src/core/tools/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/src/core/tools/CMakeLists.txt b/src/core/tools/CMakeLists.txt
index e16bfb926..8f764c94b 100644
--- a/src/core/tools/CMakeLists.txt
+++ b/src/core/tools/CMakeLists.txt
@@ -19,5 +19,15 @@ if(QT_FEATURE_webengine_spellchecker)
qt_internal_extend_target(${dict_target_name} CONDITION GCC OR CLANG
COMPILE_OPTIONS -Wno-unused-parameter
)
+ if(NOT QT_FEATURE_webengine_system_icu AND QT_WILL_INSTALL)
+ # tool can be called durig build so copy icu file
+ get_target_property(icuFile WebEngineCore ICUDTL_FILE)
+ addCopyCommand(${dict_target_name} "${icuFile}"
+ "${QT_BUILD_DIR}/${INSTALL_LIBEXECDIR}")
+ endif()
+ qt_internal_extend_target(${dict_target_name}
+ CONDITION NOT QT_FEATURE_webengine_system_icu
+ DEFINES USE_ICU_FILE
+ )
endif()