summaryrefslogtreecommitdiffstats
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
new file mode 100644
index 000000000..87383cc24
--- /dev/null
+++ b/tests/CMakeLists.txt
@@ -0,0 +1,24 @@
+if(NOT QT_BUILD_STANDALONE_TESTS)
+ cmake_minimum_required(VERSION 3.18)
+
+ include(${CMAKE_CURRENT_LIST_DIR}/../.cmake.conf)
+
+ project(QtWebEngineTests
+ VERSION "${QT_REPO_MODULE_VERSION}"
+ DESCRIPTION "Qt WebEngine Tests"
+ HOMEPAGE_URL "https://qt.io/"
+ LANGUAGES CXX C
+ )
+endif()
+
+find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core)
+find_package(Qt6 ${PROJECT_VERSION} CONFIG OPTIONAL_COMPONENTS Gui Widgets
+ WebEngineCore WebEngineWidgets WebEngineQuick QuickWidgets Test QuickTest)
+
+if(NOT QT_BUILD_STANDALONE_TESTS)
+ qt_build_repo_begin()
+ qt_build_tests()
+ qt_build_repo_end()
+else()
+ qt_build_tests()
+endif()