summaryrefslogtreecommitdiffstats
path: root/tests/auto/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/CMakeLists.txt')
-rw-r--r--tests/auto/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/tests/auto/CMakeLists.txt b/tests/auto/CMakeLists.txt
new file mode 100644
index 000000000..2227e6e46
--- /dev/null
+++ b/tests/auto/CMakeLists.txt
@@ -0,0 +1,17 @@
+if(QT_FEATURE_qtwebengine_build
+ OR (QT_BUILD_STANDALONE_TESTS AND TARGET Qt::WebEngineCore))
+ add_subdirectory(core)
+ add_subdirectory(httpserver)
+ add_subdirectory(util)
+endif()
+if(QT_FEATURE_qtwebengine_quick_build
+ OR (QT_BUILD_STANDALONE_TESTS AND TARGET Qt::WebEngineQuick))
+ add_subdirectory(quick)
+endif()
+if(QT_FEATURE_qtwebengine_widgets_build
+ OR (QT_BUILD_STANDALONE_TESTS AND TARGET Qt::WebEngineWidgets))
+ add_subdirectory(widgets)
+endif()
+#if(QT_FEATURE_build_qtpdf AND QT_FEATURE_webengine_qtpdf_support)
+# add_subdirectory(pdf)
+#endif()