summaryrefslogtreecommitdiffstats
path: root/tests/auto/quick/certificateerror/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/quick/certificateerror/CMakeLists.txt')
-rw-r--r--tests/auto/quick/certificateerror/CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/tests/auto/quick/certificateerror/CMakeLists.txt b/tests/auto/quick/certificateerror/CMakeLists.txt
new file mode 100644
index 000000000..4fe350978
--- /dev/null
+++ b/tests/auto/quick/certificateerror/CMakeLists.txt
@@ -0,0 +1,26 @@
+include(../../httpserver/httpserver.cmake)
+include(../../util/util.cmake)
+
+qt_internal_add_test(tst_certificateerror_quick
+ SOURCES
+ testhandler.cpp testhandler.h
+ tst_certificateerror.cpp
+ LIBRARIES
+ Qt::CorePrivate
+ Qt::WebEngineQuickPrivate
+ Test::HttpServer
+ Test::Util
+)
+
+set(certificateerror_resource_files
+ "resources/cert.pem"
+ "resources/key.pem"
+ "WebView.qml"
+)
+
+qt_add_resource(tst_certificateerror_quick "certificateerror"
+ PREFIX
+ "/"
+ FILES
+ ${certificateerror_resource_files}
+)