summaryrefslogtreecommitdiffstats
path: root/tools/qmake
Commit message (Collapse)AuthorAgeFilesLines
* Move qmake files to standard locationsAllan Sandfeld Jensen2017-05-0216-1118/+0
| | | | | | | | | | The tools/qmake directory is a left over from webkit where qmake was but one of many buildsystems. This is not necessary for qtwebengine, so we can instead use the standard locations. Change-Id: I3d126d6627295b113b091f3eabeee25f1c1f6183 Reviewed-by: Kai Koehne <kai.koehne@qt.io> Reviewed-by: Oswald Buddenhagen <oswald.buddenhagen@qt.io>
* Fix macOS deployment target to match the one in Qt CoreAlexandru Croitor2017-04-281-3/+0
| | | | | | | | | | | The minimum required macOS deployment target in Qt 5.9 is 10.10. This should be passed on to Chromium, rather than hardcoding the value to 10.7, which was used in pre-Qt 5.6 days to actually require a higher version than Qt Core used at the time. Task-number: QTBUG-60438 Change-Id: Id2ae47f467f8cc92403c1cd7a467335ebbba4e8e Reviewed-by: Michael Brüning <michael.bruning@qt.io>
* Make python2 usage more robustJoerg Bornemann2017-04-271-20/+19
| | | | | | | | | | | | | | | | | | | | After configuring Qt there will be an error message if a suitable python version could not be found. Add python2 configure test that - first looks for python2 in PATH - then looks for python in PATH - checks the Python version - stores the result in QMAKE_PYTHON2 Use $$QMAKE_PYTHON2 everywhere where we call python. Pass $$QMAKE_PYTHON2 to gn for its exec_script feature. Task-number: QTBUG-60164 Change-Id: I33de1273cbd20a787b3c8889d35280784dbcd5ae Reviewed-by: Oswald Buddenhagen <oswald.buddenhagen@qt.io> Reviewed-by: Michal Klocek <michal.klocek@qt.io>
* Remove unused qmake functions and helper scriptsJoerg Bornemann2017-04-211-33/+0
| | | | | Change-Id: I8d59ccc5967193db55ac00410f09506a3b040dfe Reviewed-by: Michal Klocek <michal.klocek@qt.io>
* Remove unused gyp_generator.prfJoerg Bornemann2017-04-211-160/+0
| | | | | Change-Id: I0970ee56d134be2e5186cbe14466e9739d5c6b1a Reviewed-by: Michal Klocek <michal.klocek@qt.io>
* Fixup libxml with ICU detectionv5.9.0-beta3Allan Sandfeld Jensen2017-04-211-3/+3
| | | | | | | | | The expression was not working, and didn't match what had been tested against. Task-number: QTBUG-60211 Change-Id: Id62e53fb2bf6483c58fd22c2745a4d1b5f141b1c Reviewed-by: Michal Klocek <michal.klocek@qt.io>
* Do not use system libxml if not ICU capableAllan Sandfeld Jensen2017-04-061-1/+8
| | | | | | | | | | | Using a libxml without ICU capability will break some websites, so better fall back to bundled libxml in that case. Task-number: QTBUG-59094 Change-Id: Ia24c4045ed9eb9731367cca07d8467ea9b785f2e Reviewed-by: Florian Bruhin <qt-project.org@the-compiler.org> Reviewed-by: Viktor Engelmann <viktor.engelmann@qt.io> Reviewed-by: Michael Brüning <michael.bruning@qt.io>
* Make optimize for size a visible configurable optionAllan Sandfeld Jensen2017-04-051-3/+2
| | | | | | | | Can be enabled with --optimize-for-size and is enabled by default for embedded builds. Change-Id: I955fa57804c8b7e80bb82deb83deb94a9e2a7621 Reviewed-by: Michael Brüning <michael.bruning@qt.io>
* Re-enable building with gcc 4.9.1Allan Sandfeld Jensen2017-04-041-4/+0
| | | | | | | | | The code that gcc 4.9.1 stumpled on was rewritten in Chromium 56, so we should try and let compiler build webengine again. Change-Id: I9ccec7e93aaa384aefdf338e3822b78e0dc494f2 Reviewed-by: Michal Klocek <michal.klocek@qt.io> Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org>
* Require VS 2015 update 3 or higherAllan Sandfeld Jensen2017-03-273-0/+43
| | | | | | Change-Id: I7443f28ee75aa855d2c6cce237562acd7daacf43 Reviewed-by: Michael Brüning <michael.bruning@qt.io> Reviewed-by: Peter Varga <pvarga@inf.u-szeged.hu>
* Remove blacklists of old glib and gcc 4.8 debug buildsAllan Sandfeld Jensen2017-03-262-9/+6
| | | | | | | | | | | | | We never saw the same failure with gcc 4.8 debug builds with 55-based, and the other failure suspected to related turned out not to be and have been fixed. So try to re-enable gcc 4.8 debug builds, and other old platforms but explicitly disable gcc 4.9.1 which fails to compile Chromium. Change-Id: Ib0a8ac33aafbd12d31e374dfd23f056b4ba1adf0 Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Allan Sandfeld Jensen <allan.jensen@qt.io>
* Create v8_snapshot gn toolchain from one pro fileAllan Sandfeld Jensen2017-03-251-0/+4
| | | | | | | | | | Merge the generation of the v8_snapshot toolchain back to being made in configure_host.pro. This is a lot cleaner and safer against errors, to make it work however we need to cache the target archicture so that it is still available with option(host_build) enabled. Change-Id: Iefed9c97528f8ce338e7a0d4fe5c6884fb4ef4bd Reviewed-by: Michael Brüning <michael.bruning@qt.io>
* Remove gyp handlingAllan Sandfeld Jensen2017-03-221-4/+2
| | | | | | | Remove now dead GYP related code. Change-Id: I7d5b8f28f8925e553211dc88acd571b605ffe80d Reviewed-by: Michal Klocek <michal.klocek@qt.io>
* Turn off MSVC warnings about unused variables/parametersJoerg Bornemann2017-03-221-0/+2
| | | | | | | This is consistent with what we do for gcc/clang. Change-Id: Ibda94dbc0c506c4a8053e0e3b2da25fa7dbed3a8 Reviewed-by: Allan Sandfeld Jensen <allan.jensen@qt.io>
* Fix OpenGL for embedded buildsAllan Sandfeld Jensen2017-03-201-4/+11
| | | | | | | | Sets the external ozone platform and make sure we don't set bad QT_LIBDIR defines for libEGL and libGLESv2 when not doing cross builds. Change-Id: I60eada3c93224a3aa3a105b007d669932516d331 Reviewed-by: Michal Klocek <michal.klocek@qt.io>
* Move opus, webp and ffmpeg to new configure systemAllan Sandfeld Jensen2017-03-081-14/+26
| | | | | | | | Use the new configure system to control if we are using system opus, webp and ffmpeg libraries. Change-Id: I53db66ca1668fc939a51bf7811f967468456b924 Reviewed-by: Michal Klocek <michal.klocek@qt.io>
* Merge "Merge remote-tracking branch 'origin/5.8' into 5.9" into refs/staging/5.9Allan Sandfeld Jensen2017-03-041-1/+13
|\
| * Merge remote-tracking branch 'origin/5.8' into 5.9Allan Sandfeld Jensen2017-03-021-1/+13
| |\ | | | | | | | | | Change-Id: Iff6ab3c287c58d8ec84a1513460bfce5218e8a61
| | * Fix MSVC version detectionJoerg Bornemann2017-02-141-1/+13
| | | | | | | | | | | | | | | | | | | | | | | | | | | Do not check for exactly MSVC version 14.0 but compare if the actual version is less than the requested version. Task-number: QTBUG-58826 Change-Id: I249ed3c697ccb911784a83463b1c23185c9b3856 Reviewed-by: Oswald Buddenhagen <oswald.buddenhagen@qt.io>
* | | Make xscrnsaver optionalAllan Sandfeld Jensen2017-03-021-1/+1
|/ / | | | | | | | | | | | | | | Allow building on machines where xscrnsaver is not present, but turning of the corresponding features. Change-Id: Iabf7063fcc25f68f5a9fefc95a1caf164da49fed Reviewed-by: Michal Klocek <michal.klocek@qt.io>
* | Support cross-builds and alternative compilers with GNAllan Sandfeld Jensen2017-03-012-2/+20
| | | | | | | | | | | | | | | | Adds GN versions of the gyp_configure targets, to create custom toolchains we can use to override compilers used by GN. Change-Id: Ic3a9cb7e83f845180396faff632f72f9c24f3365 Reviewed-by: Michal Klocek <michal.klocek@qt.io>
* | Simple adaptations to Chromium 55Allan Sandfeld Jensen2017-03-012-5/+16
| | | | | | | | | | | | | | The simplest adaptations to API and build changes in Chromium 55 Change-Id: I923fa188690a04902492317807f72f006bcab9c6 Reviewed-by: Michal Klocek <michal.klocek@qt.io>
* | Block debug builds with GCC 4.8Allan Sandfeld Jensen2017-02-271-2/+9
| | | | | | | | | | | | | | | | | | | | | | Skia does not mark inline functions used in optional arch cpp files with always_inline, which means they can be un-inlined and end up as in the object files where the linker will pick one at random without knowing some of them are compiled with optional arch features. Task-number: QTBUG-59154 Change-Id: I8495e04550898b093ab39c4dc0f37ad6e8948864 Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
* | Fix linkage of WebEngineCore library in gn buildPeter Varga2017-02-091-2/+4
| | | | | | | | | | Change-Id: I7ed79693cd87cd649bb8d6bea6b1397a9f6350c7 Reviewed-by: Allan Sandfeld Jensen <allan.jensen@qt.io>
* | Switch mac builds to gnMichal Klocek2017-02-061-0/+1
| | | | | | | | | | | | | | | | | | | | | | | | | | Updates chromium: cd3417b Override xcode min version to 0721 d67d4bb Remove pending messages DCHECK to stop certain tests from crashig [ChangeLog] Switch mac builds to gn Change-Id: I78111bd931f43ceb6e28d67da73f6fb2b2051c9b Reviewed-by: Allan Sandfeld Jensen <allan.jensen@qt.io> Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org>
* | Refactor release and debug handlingMichal Klocek2017-02-062-28/+9
| | | | | | | | | | | | | | | | | | | | Fix release and debug builds. Refactor ninja and gn builds as a sub projects, these are only build as release. Call core_generator and gn_run separately for debug and release builds. Change-Id: I638023214cdc98a5101d190486452cc4a1229486 Reviewed-by: Allan Sandfeld Jensen <allan.jensen@qt.io>
* | Fix framework buildsMichal Klocek2017-02-061-6/+6
| | | | | | | | | | | | | | | | Gn does not support mac_framework_dirs, pass '-F' flag instead for frameworks builds. Change-Id: Ie050b272805ae1ad14a98816a92696a9dcc017b3 Reviewed-by: Allan Sandfeld Jensen <allan.jensen@qt.io>
* | Fix escaping of double-quotesAllan Sandfeld Jensen2017-02-031-4/+9
| | | | | | | | | | | | | | | | We are using double-quoted strings and should therefore be escaping double-quotation marks and not single-quotation ones. Change-Id: I0ae3bb45365843647b38c88a22379f89843dff54 Reviewed-by: Michal Klocek <michal.klocek@qt.io>
* | Switch linux desktop builds to gnMichal Klocek2017-02-021-0/+1
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | Updates chromium: 1fd9f11 Remove linking with libatomic fa90180 Fix missing dependency on libffi b5a3338 Fix broken unit test for gn 70ea2bc Fix gn compilation for rhel6.6, rhel7.2 f408e89 Improve .pri output 492b20a Remove gtk2 dependency in tests 42e3484 Allow Service Workers without HTTP headers 7a1be30 Do not require gnome-keyring 11e5c2d Revert "Add mus and catapult project files" 891fb3a Remove various test and telemetry dependencies ddd6053 Do not use last_commit_position for gn build e85719e Windows and macOS GN integration 8fda2ae Make more features configurable 93db377 [Backport] Don't schedule wholeSubtreeInvalid sets [ChangeLog] Switch linux desktop builds to gn Change-Id: I0f766b9ee9ea65a2f92d9818ea5fb34a2e65c52d Reviewed-by: Allan Sandfeld Jensen <allan.jensen@qt.io>
* | Make WebRTC support configurableAllan Sandfeld Jensen2017-01-311-0/+1
| | | | | | | | | | | | | | | | | | | | WebRTC is a big feature that Chromium has left configurable for a long time, we can forward that configurability to our users to allow them control it directly instead of just enabling it on desktop and disabling it on embedded. Change-Id: I4445e2189112205ddf1368bd5e197bab2df92092 Reviewed-by: Michael Brüning <michael.bruning@qt.io>
* | Fix build with 5.8 and make embedded configurableAllan Sandfeld Jensen2017-01-311-3/+8
| | | | | | | | | | | | | | | | | | | | Avoid checking features only available in 5.9 directly. This also changes the embedded-build configuration to being a feature that can be set at configure time. Change-Id: I9b42dcf696734a83e5c8d6e1cc07562cbeb3f993 Reviewed-by: Michael Brüning <michael.bruning@qt.io> Reviewed-by: Michal Klocek <michal.klocek@qt.io>
* | Merge remote-tracking branch 'origin/5.8' into devLiang Qi2017-01-301-0/+5
|\ \ | |/ | | | | Change-Id: Ic36a80502730d404ab96dfa11ff1eb0ac6eb302d
| * Enforce check for minimal Windows SDK versionKai Koehne2017-01-251-0/+5
| | | | | | | | | | | | | | | | | | | | Skip build if WindowsSDKVersion environment variable is not set at all (e.g. if vcvarsall has not been called), or if it is is set to "\" - this can happen if vcvarsall.bat did not find a Windows SDK. Task-number: QTBUG-58363 Change-Id: Ieb73986a26d0b8fa28a8caa7702b830f4fb4b216 Reviewed-by: Joerg Bornemann <joerg.bornemann@qt.io>
* | macOS GN integrationAlexandru Croitor2017-01-271-5/+29
| | | | | | | | | | Change-Id: I89850d43c8f11ec54b3a47318ef0b3f083ae3dee Reviewed-by: Allan Sandfeld Jensen <allan.jensen@qt.io>
* | Add gn build of qtwebengine for linuxMichal Klocek2017-01-252-6/+12
| | | | | | | | | | | | | | | | | | | | | | This commit uses gn instead of gyp to build on desktop linux. Use WEBENGINE_CONFIG+=use_gn to use gn during the build instead of gyp. Change-Id: Ifd3d8d0835b47c323a8d39c320eb55e5e1024dee Reviewed-by: Allan Sandfeld Jensen <allan.jensen@qt.io>
* | Add pepper-plugins feature to new configure systemMichal Klocek2017-01-161-0/+2
| | | | | | | | | | | | | | | | Task-number: QTBUG-57731 Task-number: QTBUG-58108 Change-Id: I253dab52361afd411dcf545fab752836c19ee3c7 Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Allan Sandfeld Jensen <allan.jensen@qt.io>
* | Add print and pdf feature to new configure systemMichal Klocek2017-01-161-3/+1
| | | | | | | | | | | | | | | | | | | | | | | | Currently printing and pdf are bounded together. Make compilation optional by adding it as a feature. Fix formatting of embedded_linux.pri Task-number: QTBUG-57731 Task-number: QTBUG-58108 Change-Id: I53a2baea656df0a5b6139365ed06385c9ebc5830 Reviewed-by: Allan Sandfeld Jensen <allan.jensen@qt.io>
* | Enhance gn generatorMichal Klocek2017-01-121-55/+75
| | | | | | | | | | | | | | | | | | | | | | Do not generate actions if no moc_source_h_files or moc_source_cpp_files, handle correctly ldflags, add handling for lib_dirs, rpath and rpath-link. Add checks if 'libs' 'deps' 'include_dirs' comes from imports. Change-Id: Icee51e491f9f041cfce055f9e79acfade85c0b95 Reviewed-by: Allan Sandfeld Jensen <allan.jensen@qt.io>
* | Use the app-store compliance configure optionAllan Sandfeld Jensen2016-12-261-0/+1
| | | | | | | | | | | | | | Qtbase now has the option which we can follow. Change-Id: I25617b83af4ad8d4b5d10db52f10aab2c0efc58b Reviewed-by: Jake Petroules <jake.petroules@qt.io>
* | Merge branch '5.8' into devAllan Sandfeld Jensen2016-12-213-7/+47
|\ \ | |/ | | | | | | | | | | Conflicts: configure.json Change-Id: I658a02de96b45b382f0f6c383964501b794b5eb6
| * Fix Linux audio library detectionAllan Sandfeld Jensen2016-12-153-7/+47
| | | | | | | | | | | | | | | | | | The configure checks where moved to QtMultimedia which we do not depend on, therefore we need to now duplicate the checks ourselves. Task-number: QTBUG-57620 Change-Id: I6f7319c7e91e3f51baf012c669121389cd6e1360 Reviewed-by: Michael Brüning <michael.bruning@qt.io>
* | Add gn generator for pro filesMichal Klocek2016-12-161-0/+184
| | | | | | | | | | Change-Id: I5f28314d79b4aad587b323b027eb6d74ad422a73 Reviewed-by: Allan Sandfeld Jensen <allan.jensen@qt.io>
* | Add gn rebuild after bootstrapMichal Klocek2016-12-081-2/+4
| | | | | | | | | | Change-Id: I30c5a7ede2fa94fda1509443f486d05bea8b9652 Reviewed-by: Allan Sandfeld Jensen <allan.jensen@qt.io>
* | Add gn bootstrap to build systemMichal Klocek2016-12-081-0/+19
| | | | | | | | | | | | | | Bootstraps gn wihout rebuild. Change-Id: I09ee4d6b6f458f16f0d9ac18433823153ab75995 Reviewed-by: Allan Sandfeld Jensen <allan.jensen@qt.io>
* | Merge remote-tracking branch 'origin/5.8' into devMichael Brüning2016-12-072-1/+4
|\ \ | |/ | | | | | | | | | | Conflicts: src/3rdparty Change-Id: Ie7b7c469aa24716816a23b8fe7a8df9f477a9f67
| * Move the QPrinter and QtWidgets related code out of the PDFium wrapperMichael Brüning2016-11-251-0/+3
| | | | | | | | | | | | | | | | | | | | | | This moves the actual printing using QPrinter to the WebEngineWidgets part of the API. The printsupport module depends on the widgets module and therefore QtWebEngineCore also had a dependency to widgets. This is removed by this change. Change-Id: If6e5745709a59de18f2123b930cbe6e64390c867 Reviewed-by: Michal Klocek <michal.klocek@qt.io>
| * Merge remote-tracking branch 'origin/5.7' into 5.8Allan Sandfeld Jensen2016-11-251-1/+1
| |\ | | | | | | | | | | | | | | | | | | Conflicts: src/3rdparty Change-Id: Ib9c9eca457c1c42dab948e6cb56d44b57d5da32a
| | * Merge branch '5.6' into 5.7Allan Sandfeld Jensen2016-11-241-1/+1
| | |\ | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | Conflicts: src/core/api/qwebengineurlrequestinfo.cpp src/core/api/qwebengineurlrequestinfo.h src/core/core_gyp_generator.pro Change-Id: I5c78f0c86f6dcd61697148f0729d3d3a2cb2c76f
| | | * Check if the .git directory exists before invoking gitAndy Shaw2016-11-101-1/+1
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | If .git does not exist then this is not from a git build and therefore there is no reason to invoke git (which might not even exist on the system anyway). This prevents an error appearing due to trying to invoke git on Windows when it does not exist. Change-Id: I8c0b5b237cfdaffdbb33efdd16cf20cd1560f1a1 Reviewed-by: Joerg Bornemann <joerg.bornemann@qt.io>
* | | | Split ninja target into runninja and buildninja in gyp_runMichal Klocek2016-12-021-11/+12
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | Small refactor to split the targets in makefile. Bootstrapping gn will need also ninja build. Change-Id: Id177a0189b79cf353b6bd27c4e087f4e960f56c2 Reviewed-by: Michael Brüning <michael.bruning@qt.io>