summaryrefslogtreecommitdiffstats
path: root/Source/WTF/wtf/CMakeLists.txt
diff options
context:
space:
mode:
authorBalazs Kilvady <kilvadyb@homejinni.com>2013-02-26 18:55:12 +0000
committerThe Qt Project <gerrit-noreply@qt-project.org>2013-05-23 13:39:23 +0200
commitdfd49c6f90bbe10a4e0c0e74768b3696f60b796c (patch)
treedfb605db83d5dba27c1739018dbbe02e4cc85d17 /Source/WTF/wtf/CMakeLists.txt
parent765fd0c6ebdfbd1a0540211bc8b58e46076b41a3 (diff)
Fix the atomicIncrement implementation for MIPS GCC
https://bugs.webkit.org/show_bug.cgi?id=106739 Patch by Balazs Kilvady <kilvadyb@homejinni.com> on 2013-02-26 Reviewed by Oliver Hunt. Implementation of missing __sync_[add|sub]_and_fetch_8 functions. Some architectures, like MIPS32, don't have GCC implementation for builtin __sync_* functions with 64 bits variable size. GCC answer for the problem: If a target doesn't support atomic operations on certain variable sizes, you are out of luck with atomicity in that case (http://gcc.gnu.org/bugzilla/show_bug.cgi?id=56296). GCC >= 4.8 will support __atomic_* builtin functions for this purpose for all the GCC targets, but for current compilers we have to include our own implementation. * GNUmakefile.list.am: * WTF.pro: * wtf/Atomics.cpp: Added. (WTF): (WTF::getSwapLock): (WTF::atomicStep): * wtf/CMakeLists.txt: git-svn-id: http://svn.webkit.org/repository/webkit/trunk@144077 268f45cc-cd09-0410-ab3c-d52691b4dbfc Conflicts: Source/WTF/ChangeLog Change-Id: I98ce0ccd6747253ae6fa36fe9d338e155945a043 Reviewed-by: Allan Sandfeld Jensen <allan.jensen@digia.com> Reviewed-by: Jocelyn Turcotte <jocelyn.turcotte@digia.com>
Diffstat (limited to 'Source/WTF/wtf/CMakeLists.txt')
-rw-r--r--Source/WTF/wtf/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Source/WTF/wtf/CMakeLists.txt b/Source/WTF/wtf/CMakeLists.txt
index 9ba49504b..b7f437c64 100644
--- a/Source/WTF/wtf/CMakeLists.txt
+++ b/Source/WTF/wtf/CMakeLists.txt
@@ -157,6 +157,7 @@ SET(WTF_SOURCES
ArrayBuffer.cpp
ArrayBufferView.cpp
Assertions.cpp
+ Atomics.cpp
BitVector.cpp
CryptographicallyRandomNumber.cpp
CurrentTime.cpp