summaryrefslogtreecommitdiffstats
path: root/Source/JavaScriptCore/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Source/JavaScriptCore/CMakeLists.txt')
-rw-r--r--Source/JavaScriptCore/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/Source/JavaScriptCore/CMakeLists.txt b/Source/JavaScriptCore/CMakeLists.txt
index 1504e53a8..d570b8dd0 100644
--- a/Source/JavaScriptCore/CMakeLists.txt
+++ b/Source/JavaScriptCore/CMakeLists.txt
@@ -1318,6 +1318,8 @@ if (${JavaScriptCore_LIBRARY_TYPE} STREQUAL "SHARED")
install(TARGETS JavaScriptCore DESTINATION "${LIB_INSTALL_DIR}")
endif ()
+QT_ADD_EXTRA_WEBKIT_TARGET_EXPORT(JavaScriptCore)
+
# Force staging of shared scripts, even if they aren't directly used to build JavaScriptCore.
add_custom_target(stageSharedScripts DEPENDS ${JavaScriptCore_SCRIPTS})