summaryrefslogtreecommitdiffstats
path: root/Source/ThirdParty/gtest/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Source/ThirdParty/gtest/CMakeLists.txt')
-rw-r--r--Source/ThirdParty/gtest/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/Source/ThirdParty/gtest/CMakeLists.txt b/Source/ThirdParty/gtest/CMakeLists.txt
index cea356f1e..51c8f91ca 100644
--- a/Source/ThirdParty/gtest/CMakeLists.txt
+++ b/Source/ThirdParty/gtest/CMakeLists.txt
@@ -39,7 +39,7 @@ add_definitions(-DGTEST_HAS_RTTI=0)
# FIXME: This works around compatibility problems in the old version of the third-pary
# googletest source code checkout. It should be removed once we upgrade to a newer version.
-if ("${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang")
+if (COMPILER_IS_CLANG)
add_definitions(-DGTEST_HAS_TR1_TUPLE=0)
endif ()