summaryrefslogtreecommitdiffstats
path: root/Source/ThirdParty/woff2/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Source/ThirdParty/woff2/CMakeLists.txt')
-rw-r--r--Source/ThirdParty/woff2/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/Source/ThirdParty/woff2/CMakeLists.txt b/Source/ThirdParty/woff2/CMakeLists.txt
index 075ab5a62..e8f7cf2aa 100644
--- a/Source/ThirdParty/woff2/CMakeLists.txt
+++ b/Source/ThirdParty/woff2/CMakeLists.txt
@@ -9,6 +9,7 @@ set(WOFF2_SOURCES
${WOFF2_DIR}/src/variable_length.cc
${WOFF2_DIR}/src/woff2_common.cc
${WOFF2_DIR}/src/woff2_dec.cc
+ ${WOFF2_DIR}/src/woff2_out.cc
)
include_directories("${THIRDPARTY_DIR}/brotli/dec")
@@ -18,9 +19,11 @@ target_link_libraries(woff2 brotli)
WEBKIT_SET_EXTRA_COMPILER_FLAGS(woff2)
if (COMPILER_IS_GCC_OR_CLANG)
- ADD_TARGET_PROPERTIES(woff2 COMPILE_FLAGS "-Wno-sign-compare")
+ ADD_TARGET_PROPERTIES(woff2 COMPILE_FLAGS "-Wno-sign-compare -Wno-unused-variable -Wno-unused-parameter")
endif ()
if (CMAKE_COMPILER_IS_GNUCXX)
ADD_TARGET_PROPERTIES(woff2 COMPILE_FLAGS "-Wno-unused-but-set-variable")
endif ()
+
+QT_ADD_EXTRA_WEBKIT_TARGET_EXPORT(woff2)